Bug 144760 - /etc/hotplug/usb/usbcam has incorrect path, leading to permission errors
/etc/hotplug/usb/usbcam has incorrect path, leading to permission errors
Status: CLOSED DUPLICATE of bug 144761
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
http://blog.subverted.net/personal/im...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 07:11 EST by Wade Mealing
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2005-01-11 07:11:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.5)
Gecko/20041112 Firefox/1.0

Description of problem:
From the screenshot provided, it seems as though the path for the
console.lock files are incorrect.

This leads to the permissions on USB cameras being plugged in to have
the incorrect permissions.

Should be something like this..

	if [ -f /var/run/console/console.lock ]
	then
        	CONSOLEOWNER=`cat /var/run/console/console.lock`
	elif [ -f /var/lock/console/console.lock ]
    		then
        CONSOLEOWNER=`cat /var/lock/console/console.lock`
	else
        	CONSOLEOWNER=
    	fi




Version-Release number of selected component (if applicable):
hotplug-2004_04_01-6

How reproducible:
Always

Steps to Reproduce:
1. Plug in USB camera, wait for gphoto2 to start
2. Error message in url appears
3. Ponder the meaning of life.

Actual Results:  Error message in URL shown

Expected Results:  Gphoto2 to start and begin importing photos .. no
permission errors .. meaning of life to be revealed.

Additional info:

Seems like it is a problem with FC3 and rawhide, seems to be fixed in
RHEL 4, although I didnt get to check how it was fixed, but I'm
guessing this is how.
Comment 1 Bill Nottingham 2005-01-11 12:50:29 EST

*** This bug has been marked as a duplicate of 144761 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.