Bug 1447767 - [3.4] During cluster issues, node left mounts on the nodes referring to Persistent Storage, these mounts removed all the data from the PVs
[3.4] During cluster issues, node left mounts on the nodes referring to Persi...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.4.1
Unspecified Unspecified
unspecified Severity high
: ---
: 3.4.z
Assigned To: hchen
Jianwei Hou
:
Depends On: 1447763 1447312 1447764 1447765
Blocks: 1447768
  Show dependency treegraph
 
Reported: 2017-05-03 14:43 EDT by Bradley Childs
Modified: 2017-06-15 14:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: During cluster issues, node left mounts on the nodes referring to Persistent Storage, these mounts removed all the data from the PV. Consequence: Data on the PVs are deleted. Fix: Cleaning up Pods on the nodes doesn't delete data on PVs. Result: Data on the PVs are no longer deleted during Pods cleanup.
Story Points: ---
Clone Of: 1447765
: 1447768 (view as bug list)
Environment:
Last Closed: 2017-06-15 14:38:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1425 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.2 bug fix update 2017-06-15 18:35:53 EDT

  None (edit)
Comment 1 Eric Paris 2017-05-11 11:53:42 EDT
https://github.com/openshift/ose/pull/729
Comment 3 Jianwei Hou 2017-05-24 04:14:45 EDT
Verified on v3.4.1.27

Steps:
1. Create NFS PV and create an  app using the jenkins-persistent template.
2. Once the jenkins pod is running, bring down the node by stopping it's node service.
3. The pod will be redeployed to another schedulable node.
4. After the pod is deployed to another node, bring back the stopped node service.
5. On the original node, verify the jenkins pod volume is successfully unmounted, the pod directory is removed while all data in the persistent volume are still there.
Comment 5 errata-xmlrpc 2017-06-15 14:38:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1425

Note You need to log in before you can comment on or make changes to this bug.