Bug 144803 - totem fails to play audio CDs
totem fails to play audio CDs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On: 137250
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 12:20 EST by Ignacio Vazquez-Abrams
Modified: 2013-03-13 00:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 15:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2005-01-11 12:20:38 EST
When using Movie | Play Disc, totem 0:0.99.19-1 comes back with an error saying
"Totem could not play 'cdda://'. Failed to open; reason unknown". On the
terminal "** (totem:30750): WARNING **: don't know how to read cdda://" appears.
xine and mplayer from livna both have no issue with playing it.
Comment 1 John Thacker 2005-01-31 15:55:18 EST
This is completely because of bug #137250 and a problem with gnome-vfs2.
Comment 2 Bastien Nocera 2005-05-10 17:38:06 EDT
I added this small work-around in bug #137250. Run this command as root:
perl -pi~ -e "s,cdda,#cdda," /etc/gnome-vfs-2.0/modules/default-modules.conf
Comment 3 John Thacker 2006-02-24 14:52:34 EST
Currently totem *still* doesn't play audio cds.  Even if the cdda module is
commented out.  Or rather, here's the behavior, with an audio disc inserted:

"totem cdda://" - plays audio disc
"totem cdda://tracknum" - plays track
"totem cdda://dev/hdc" (or some such) - error, unknown URI
"totem" and try to select from menu - "Play Disc 'Audio Disc'" is greyed out and
can't be selected.
Comment 4 John Thacker 2006-02-24 15:09:29 EST
Of course, reading through the development lists and totem CVS, it may be that
this is intentional behavior, and CD playing was disabled in order to not
compete with sound-juicer and rhythmbox.  If so, please feel free to close the bug.
Comment 5 John (J5) Palmieri 2006-02-24 15:12:37 EST
Basicly it never really worked right and we have so many programs that handle it
better (and make more sense to handle it) that totem decided to drop support for
doing so.  Closing bug.

Note You need to log in before you can comment on or make changes to this bug.