Bug 1448076 - discover-tempest-config fails to find swift endpoint
Summary: discover-tempest-config fails to find swift endpoint
Keywords:
Status: CLOSED DUPLICATE of bug 1252600
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tempestconf
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Chandan Kumar
QA Contact: Martin Kopec
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-04 13:32 UTC by Gonéri Le Bouder
Modified: 2017-05-04 15:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-04 15:10:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gonéri Le Bouder 2017-05-04 13:32:25 UTC
Description of problem:

I used an environment that has been upgraded fro OSP10 to OSP11. The public Swift is at http://192.168.250.225:8080/swift/v1 but discover-tempest-config try to use http://192.168.250.225:8080 instead. It fails with a back trace. Swift client works fine. I can upload/list/download object.

[stack@director tempest]$ openstack endpoint show swift                                                                                                                                                              
+--------------+--------------------------------------+
| Field        | Value                                |
+--------------+--------------------------------------+
| adminurl     | http://192.168.170.27:8080/swift/v1  |
| enabled      | True                                 |
| id           | 13f76a3e5031443085990ad57efaf599     |
| internalurl  | http://192.168.170.27:8080/swift/v1  |
| publicurl    | http://192.168.250.225:8080/swift/v1 |
| region       | regionOne                            |
| service_id   | 7fa8329970454e619d0d97427d32c6a6     |
| service_name | swift                                |
| service_type | object-store                         |
+--------------+--------------------------------------+


[stack@director tempest]$ discover-tempest-config                                                                                                                                                                    
2017-05-04 08:24:51.214 14498 INFO tempest [-] Using tempest config file /etc/tempest/tempest.conf
2017-05-04 08:24:51.398 14498 WARNING config_tempest.config_tempest [-] Could not load some identity admin options from /home/stack/tempest/etc/default-overrides.conf
2017-05-04 08:24:51.557 14498 INFO tempest.lib.common.rest_client [req-16747640-ba01-41a6-8598-d1e8e62f0690 ] Request (main): 200 POST http://192.168.250.225:5000/v2.0/tokens
2017-05-04 08:24:51.651 14498 INFO tempest.lib.common.rest_client [req-e2447966-428d-4232-8b14-405d320e31fa ] Request (main): 200 GET http://192.168.120.109:35357/v2.0/tenants 0.093s
2017-05-04 08:24:52.917 14498 CRITICAL tempest [-] ServiceError: Request on service 'object-store' with url 'http://192.168.250.225:8080/info' failed with code 404
2017-05-04 08:24:52.917 14498 ERROR tempest Traceback (most recent call last):
2017-05-04 08:24:52.917 14498 ERROR tempest   File "/bin/discover-tempest-config", line 10, in <module>
2017-05-04 08:24:52.917 14498 ERROR tempest     sys.exit(main())
2017-05-04 08:24:52.917 14498 ERROR tempest   File "/usr/lib/python2.7/site-packages/config_tempest/config_tempest.py", line 168, in main
2017-05-04 08:24:52.917 14498 ERROR tempest     'disable_ssl_certificate_validation'
2017-05-04 08:24:52.917 14498 ERROR tempest   File "/usr/lib/python2.7/site-packages/config_tempest/api_discovery.py", line 206, in discover
2017-05-04 08:24:52.917 14498 ERROR tempest     services[name]['extensions'] = service.get_extensions()
2017-05-04 08:24:52.917 14498 ERROR tempest   File "/usr/lib/python2.7/site-packages/config_tempest/api_discovery.py", line 122, in get_extensions
2017-05-04 08:24:52.917 14498 ERROR tempest     top_level_path="info")
2017-05-04 08:24:52.917 14498 ERROR tempest   File "/usr/lib/python2.7/site-packages/config_tempest/api_discovery.py", line 61, in do_get
2017-05-04 08:24:52.917 14498 ERROR tempest     " with code %d" % (self.name, url, r.status))
2017-05-04 08:24:52.917 14498 ERROR tempest ServiceError: Request on service 'object-store' with url 'http://192.168.250.225:8080/info' failed with code 404
2017-05-04 08:24:52.917 14498 ERROR tempest


[stack@director tempest]$ curl http://192.168.250.225:8080/swift/info
{"bulk_delete":{},"container_quotas":{},"swift":{"max_file_size":5368709120,"container_listing_limit":10000,"version":"10.2.5-37.el7cp","max_meta_name_length":81,"policies":[{"default":true,"name":"default-placement"}],"max_object_name_size":1024,"strict_cors_mode":true,"max_container_name_length":255},"tempurl":{"methods":["GET","HEAD","PUT","POST","DELETE"]},"slo":{"max_manifest_segments":1000},"account_quotas":{},"staticweb":{},"tempauth":{}}


[stack@director tempest]$ rpm -qa|grep tempest                                                                                                                                                                       
python-tempest-tests-15.0.0-2.el7ost.noarch
puppet-tempest-10.3.0-3.el7ost.noarch
python-tempest-15.0.0-2.el7ost.noarch
openstack-tempest-15.0.0-2.el7ost.noarch
python-tempestconf-1.1.1-1.el7ost.noarch

Comment 1 Gonéri Le Bouder 2017-05-04 15:10:51 UTC
Dup, associated bugs:
https://access.redhat.com/solutions/2858981
https://bugzilla.redhat.com/show_bug.cgi?id=1413164
https://bugzilla.redhat.com/show_bug.cgi?id=1252600

*** This bug has been marked as a duplicate of bug 1252600 ***


Note You need to log in before you can comment on or make changes to this bug.