Bug 144814 - Gedit crashes when started with argument and from Nautilus.
Gedit crashes when started with argument and from Nautilus.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gedit (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 13:44 EST by Rick James
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 09:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick James 2005-01-11 13:44:35 EST
Description of problem: Issuing 'gedit filename.txt' or right-
clicking the text file from Nautilus and choosing Open With | Gedit 
causes it to crash.  Starting Gedit alone, then using Open to browse 
to the file works.

Version-Release number of selected component (if applicable): gedit-
2.2.2-1 for ia64


How reproducible: Start gedit from the CLI with filename argument or 
right-click the filename and choose Open With | Gedit.


Steps to Reproduce:
1. Start Nautilus.
2. Browse to text file.
3. Right-click and chose Open With | Gedit.
  
Actual results: GLib-ERROR **: gmem.c:140: failed to allocate 
6917529027641099397 bytes aborting...


Expected results: The text file should open in gedit.


Additional info: Doesn't look good when the default text editor 
crashes in an 'Enterprise' OS.
Comment 1 Dan Williams 2005-01-11 14:03:05 EST
This is already filed, and has been fixed (Bug 137430, RHBA-2004:618).
 The fix will come out with RHEL3 Update 5 as it was too late for U4.
 Please download the test packages at
http://people.redhat.com/dcbw/gedit-2.2.2-3.ia64.rpm and report here
if they fix the problem or not.

Thanks!
Comment 2 Dan Williams 2005-01-11 14:08:27 EST
Marking as dupe of Bug 103933

*** This bug has been marked as a duplicate of 103933 ***
Comment 3 Tim Powers 2005-05-19 09:19:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-438.html

Note You need to log in before you can comment on or make changes to this bug.