Bug 103933 - gedit crash on file load from shell
Summary: gedit crash on file load from shell
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gedit   
(Show other bugs)
Version: 3.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: CambridgeBlocker 101028 132991
TreeView+ depends on / blocked
 
Reported: 2003-09-08 00:30 UTC by jahshaka
Modified: 2007-11-30 22:06 UTC (History)
3 users (show)

Fixed In Version: 2.4.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 20:02:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for this bug (346 bytes, patch)
2003-09-09 16:35 UTC, Matt Wilson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:438 normal SHIPPED_LIVE Updated gedit package 2005-05-19 04:00:00 UTC

Description jahshaka 2003-09-08 00:30:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.4) Gecko/20030902

Description of problem:
Gedit launches no problem, and lets you enter and modify data if you lunch it on
its own first. However if you try to open a file from the shell it crashes.

I get the following error when i try to launch 
>gedit filename

GLib-ERROR **: gmem.c:140: failed to allocate 6917529027641116335 bytes
aborting...






Version-Release number of selected component (if applicable):
glib-1.2.10-11.1 libgnome-2.2.2-6

How reproducible:
Always

Steps to Reproduce:
1. gedit filename
2. crash
3.
    

Actual Results:  crashes every time

Expected Results:  it should have opened the file

Additional info:

Comment 1 Matt Wilson 2003-09-09 16:29:33 UTC
gedit-document.c:670: warning: passing arg 2 of `eel_read_entire_file' from
incompatible pointer type


Comment 2 Matt Wilson 2003-09-09 16:35:42 UTC
Created attachment 94333 [details]
fix for this bug

Comment 3 jahshaka 2003-09-25 06:59:09 UTC
has this patch been added into the latest up2date downloads ? i just updated my
system and its still there...

>gedit install.log
 
GLib-ERROR **: gmem.c:140: failed to allocate 6917529027641116856 bytes
aborting...


Comment 4 Havoc Pennington 2003-10-08 20:23:33 UTC
This fix hasn't been incorporated yet, that I see.

Comment 5 Matt Wilson 2003-10-21 20:02:18 UTC
in 2.4.0-3

Comment 6 Tony Ernst 2004-07-22 15:04:16 UTC
Will there be an errata issued for this anytime soon?  I had hoped
that an updated gedit rpm might be included in RHEL 3 Update 2, but it
wasn't.  Thanks.


Comment 8 Dan Williams 2005-01-11 19:07:50 UTC
Tony:

Please grab package from:

http://people.redhat.com/dcbw/gedit-2.2.2-3.ia64.rpm

and report if it works...  This fix is currently targetted at RHEL3 U5.

Thanks!


Comment 9 Dan Williams 2005-01-11 19:08:29 UTC
*** Bug 144814 has been marked as a duplicate of this bug. ***

Comment 10 Tony Ernst 2005-01-11 20:49:58 UTC
Dan,

Yes, that fixes the problem.

Thank you!

-tony


Comment 11 Rick James 2005-01-11 21:32:56 UTC
Dan,

The gedit-2.2.2-3 patch fixed the problem here.

Thanks,
Rick

Comment 12 Jay Turner 2005-04-07 11:28:49 UTC
Fix confirmed with 2.2.2-4 which is scheduled to go out as part of U5 update.

Comment 13 Tim Powers 2005-05-19 13:19:08 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-438.html



Note You need to log in before you can comment on or make changes to this bug.