Bug 1448307 - Seeing Input/Output error in rebalance logs during a rebalance on an ec volume(log level=Debug)
Summary: Seeing Input/Output error in rebalance logs during a rebalance on an ec volum...
Keywords:
Status: CLOSED DUPLICATE of bug 1454686
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Sunil Kumar Acharya
QA Contact:
URL:
Whiteboard:
Depends On: 1447559
Blocks: glusterfs-3.11.0 1448293 1454686
TreeView+ depends on / blocked
 
Reported: 2017-05-05 07:12 UTC by Nithya Balachandran
Modified: 2017-05-26 03:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1447559
Environment:
Last Closed: 2017-05-26 03:09:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Nithya Balachandran 2017-05-05 07:14:07 UTC
Rebalance fails to migrate files on EC volumes:


[2017-05-03 07:37:35.643291] E [MSGID: 109023] [dht-rebalance.c:740:__dht_rebalance_create_dst_file] 0-ecv-dht: fallocate failed for /dir1/linux-4.10.4/include/linux/smpboot.h on ecv-disperse-1 (Operation not supported)
[2017-05-03 07:37:35.643320] E [MSGID: 0] [dht-rebalance.c:1516:dht_migrate_file] 0-ecv-dht: Create dst failed on - ecv-disperse-1 for file - /dir1/linux-4.10.4/include/linux/smpboot.h



RCA: 

The rebalance code was recently changed to use fallocate when creating the dst file. However it looks like this is not supported on EC volumes:


 736 int32_t ec_gf_fallocate(call_frame_t * frame, xlator_t * this, fd_t * fd,       
 737                         int32_t keep_size, off_t offset, size_t len,            
 738                         dict_t * xdata)                                         
 739 {                                                                               
 740     default_fallocate_failure_cbk(frame, ENOTSUP);                              
 741                                                                                 
 742     return 0;                                                                   
 743 }  


With this change, rebalance will fail on EC volumes.

Comment 2 Pranith Kumar K 2017-05-26 03:09:21 UTC

*** This bug has been marked as a duplicate of bug 1454686 ***


Note You need to log in before you can comment on or make changes to this bug.