Bug 1454686 - Implement FALLOCATE FOP for EC
Summary: Implement FALLOCATE FOP for EC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Sunil Kumar Acharya
QA Contact:
URL:
Whiteboard:
: 1448307 (view as bug list)
Depends On: 1447559 1448293 1448307
Blocks: glusterfs-3.11.0
TreeView+ depends on / blocked
 
Reported: 2017-05-23 10:35 UTC by Sunil Kumar Acharya
Modified: 2017-05-30 18:53 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1448293
Environment:
Last Closed: 2017-05-30 18:53:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-05-23 10:47:03 UTC
REVIEW: https://review.gluster.org/17369 (cluster/ec: Implement FALLOCATE FOP for EC) posted (#1) for review on release-3.11 by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 2 Worker Ant 2017-05-25 13:13:02 UTC
COMMIT: https://review.gluster.org/17369 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 4691f6d375529ffec94f722a644b31c6cb826ddb
Author: Sunil Kumar Acharya <sheggodu@redhat.com>
Date:   Wed May 17 14:35:41 2017 +0530

    cluster/ec: Implement FALLOCATE FOP for EC
    
    FALLOCATE file operations is not implemented in the
    existing EC code. This change set implements it
    for EC.
    
    >BUG: 1448293
    >Change-Id: Id9ed914db984c327c16878a5b2304a0ea461b623
    >Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>
    >Reviewed-on: https://review.gluster.org/15200
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    
    BUG: 1454686
    Change-Id: Id9ed914db984c327c16878a5b2304a0ea461b623
    Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>
    Reviewed-on: https://review.gluster.org/17369
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ashish Pandey <aspandey@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Pranith Kumar K 2017-05-26 03:09:21 UTC
*** Bug 1448307 has been marked as a duplicate of this bug. ***

Comment 4 Shyamsundar 2017-05-30 18:53:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.