Bug 1449217 - gdeploy has to be rebuilt to be compatible with ansible 2.3
Summary: gdeploy has to be rebuilt to be compatible with ansible 2.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-3 1417151 1450320 1451442 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-05-09 12:30 UTC by RamaKasturi
Modified: 2017-09-21 04:49 UTC (History)
7 users (show)

Fixed In Version: gdeploy-2.0.2-7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1450320 (view as bug list)
Environment:
Last Closed: 2017-09-21 04:49:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2777 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL7 2017-09-21 08:23:08 UTC

Description RamaKasturi 2017-05-09 12:30:26 UTC
Description of problem:
ansible-2.3 no longer considers the path where gdeploy modules are kept which is ansible/modules/extras. For ansible 2.3 to work there requires a spec file change in gdeploy and it has to be rebuilt. 



Version-Release number of selected component (if applicable):
gdeploy-2.0.1-11.el7rhgs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have ansible 2.3 and latest gdeploy installed on the system.
2. 
3.

Actual results:
gdeploy does not run successfully and results into syntax errors. A snip of the errors are present here.

The error appears to have been in '/tmp/tmpDZeVcQ/pvcreate.yml': line 16, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  # Create pv on all the disks
  - name: Create Physical Volume
    ^ here


The error appears to have been in '/tmp/tmpDZeVcQ/pvcreate.yml': line 16, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  # Create pv on all the disks
  - name: Create Physical Volume
    ^ here
Ignoring errors...
ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/tmp/tmpDZeVcQ/vgcreate.yml': line 8, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
  - name: Create volume group on the disks
    ^ here


The error appears to have been in '/tmp/tmpDZeVcQ/vgcreate.yml': line 8, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
  - name: Create volume group on the disks
    ^ here
Ignoring errors...
ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/tmp/tmpDZeVcQ/lvcreate.yml': line 7, column 9, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
      - name: Create LVs with specified size for the VGs
        ^ here


The error appears to have been in '/tmp/tmpDZeVcQ/lvcreate.yml': line 7, column 9, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
      - name: Create LVs with specified size for the VGs
        ^ here
+ RET_CODE=1
+ '[' 1 -ne 0 ']'
+ echo 'gdeploy setup on lago-hc-basic-suite-4-1-host0 failed with status 1.'
gdeploy setup on lago-hc-basic-suite-4-1-host0 failed with status 1.
+ exit 1


Expected results:
gdeploy should run successfully with ansible 2.3 version.

Additional info:

Comment 5 Manisha Saini 2017-07-04 10:20:35 UTC
Verified this with


# rpm -qa | grep gdeploy
gdeploy-2.0.2-12.el7rhgs.noarch

# rpm -qa | grep ansible
ansible-2.3.0.0-3.el7.noarch


Ran the following config file for backend setup followed by volume creation and
ganesha setup. Works fine with this build

[hosts]
dhcp42-125.lab.eng.blr.redhat.com
dhcp42-127.lab.eng.blr.redhat.com
dhcp42-129.lab.eng.blr.redhat.com
dhcp42-119.lab.eng.blr.redhat.com
#dhcp42-117.lab.eng.blr.redhat.com
#dhcp42-114.lab.eng.blr.redhat.com
#dhcp42-107.lab.eng.blr.redhat.com
#dhcp42-88.lab.eng.blr.redhat.com



[backend-setup]
devices=/dev/sdb,/dev/sdc,/dev/sdd
vgs=vg1,vg2,vg3
pools=pool1,pool2,pool3
lvs=lv1,lv2,lv3
mountpoints=/gluster/brick1,/gluster/brick2,/gluster/brick3
brick_dirs=/gluster/brick1/1,/gluster/brick2/1,/gluster/brick3/1

[firewalld]
action=add
ports=111/tcp,2049/tcp,54321/tcp,5900/tcp,5900-6923/tcp,5666/tcp,16514/tcp
services=glusterfs,nlm,nfs,rpc-bind,high-availability,mountd,rquota


[volume1]
action=create
volname=ganeshavol1
transport=tcp
replica_count=2
force=yes
brick_dirs=/gluster/brick1/1,/gluster/brick2/1,/gluster/brick3/1

[volume2]
action=create
volname=ganeshavol4
transport=tcp
replica_count=2
force=yes
brick_dirs=/gluster/brick1/4,/gluster/brick2/4,/gluster/brick3/4

[volume3]
action=create
volname=ganeshavol5
transport=tcp
replica_count=2
force=yes
brick_dirs=/gluster/brick1/5,/gluster/brick2/5,/gluster/brick3/5


[volume3]
action=create
volname=ganeshavol3
transport=tcp
replica_count=2
force=yes
brick_dirs=/gluster/brick1/3,/gluster/brick2/3,/gluster/brick3/3

[nfs-ganesha]
action=create-cluster
ha-name=ganesha-ha-360
cluster-nodes=dhcp42-125.lab.eng.blr.redhat.com,dhcp42-127.lab.eng.blr.redhat.com,dhcp42-129.lab.eng.blr.redhat.com,dhcp42-119.lab.eng.blr.redhat.com
vip=10.70.42.40,10.70.42.41,10.70.42.42,10.70.42.43

Comment 6 Manisha Saini 2017-07-04 10:21:05 UTC
Based on comment #5,moving it to verified state

Comment 8 errata-xmlrpc 2017-09-21 04:49:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777


Note You need to log in before you can comment on or make changes to this bug.