Bug 1450320 - [3.2.0_async] [RHEL7] gdeploy has to be rebuilt to be compatible with ansible 2.3
Summary: [3.2.0_async] [RHEL7] gdeploy has to be rebuilt to be compatible with ansible...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.2.0 Async
Assignee: Sachidananda Urs
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On: 1449217
Blocks: Gluster-HC-2 1451442
TreeView+ depends on / blocked
 
Reported: 2017-05-12 09:14 UTC by SATHEESARAN
Modified: 2017-05-25 17:04 UTC (History)
11 users (show)

Fixed In Version: gdeploy-2.0.1-13
Doc Type: Enhancement
Doc Text:
Feature: gdeploy is updated to work with Ansible 2.3. Reason: Current version of ansible has removed the support for extras/ module directory in their version 2.3. gdeploy used to ship the modules which were placed in this directory. Playbook conditional was changed in Ansible 2.3, playbooks for gdeploy had to be modified to accommodate these changes. Result: gdeploy installer was modified to install the modules in search path. And the playbooks updated to work with Ansible release.
Clone Of: 1449217
: 1451442 (view as bug list)
Environment:
Last Closed: 2017-05-25 17:04:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1333 normal SHIPPED_LIVE gdeploy bug fix update 2017-05-25 21:03:43 UTC

Description SATHEESARAN 2017-05-12 09:14:03 UTC
Description of problem:
-----------------------
Ansible-2.3 no longer considers the path where gdeploy modules are kept which is ansible/modules/extras. For ansible 2.3 to work there requires a spec file change in gdeploy and it has to be rebuilt. 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.1-11.el7rhgs.noarch

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Have ansible 2.3 and latest gdeploy installed on the system.

Actual results:
----------------
gdeploy does not run successfully and results into syntax errors. A snip of the errors are present here.

The error appears to have been in '/tmp/tmpDZeVcQ/pvcreate.yml': line 16, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  # Create pv on all the disks
  - name: Create Physical Volume
    ^ here


The error appears to have been in '/tmp/tmpDZeVcQ/pvcreate.yml': line 16, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  # Create pv on all the disks
  - name: Create Physical Volume
    ^ here
Ignoring errors...
ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/tmp/tmpDZeVcQ/vgcreate.yml': line 8, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
  - name: Create volume group on the disks
    ^ here


The error appears to have been in '/tmp/tmpDZeVcQ/vgcreate.yml': line 8, column 5, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
  - name: Create volume group on the disks
    ^ here
Ignoring errors...
ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/tmp/tmpDZeVcQ/lvcreate.yml': line 7, column 9, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
      - name: Create LVs with specified size for the VGs
        ^ here


The error appears to have been in '/tmp/tmpDZeVcQ/lvcreate.yml': line 7, column 9, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  tasks:
      - name: Create LVs with specified size for the VGs
        ^ here
+ RET_CODE=1
+ '[' 1 -ne 0 ']'
+ echo 'gdeploy setup on lago-hc-basic-suite-4-1-host0 failed with status 1.'
gdeploy setup on lago-hc-basic-suite-4-1-host0 failed with status 1.
+ exit 1

Expected results:
-----------------
gdeploy should run successfully with ansible 2.3 version.


--- Additional comment from SATHEESARAN on 2017-05-10 03:58:58 EDT ---

Its is essential to have gdeploy supported with Ansible-2.3 because RHV-H will be pulling the latest Ansible 2.3. The fix will help in the HC deployment with RHV-H ( containing Ansible-2.3 )

Comment 3 Manisha Saini 2017-05-25 09:33:31 UTC
Verified this bug with

gdeploy-2.0.1-13.el7rhgs 
ansible-2.3.0.0-3.el7

Comment 4 SATHEESARAN 2017-05-25 11:55:54 UTC
In addition to comment3, tested with the basic test with ansible-2.2.3 and ansible-2.3

Kasturi has also verified the same with ansible-2.3

Comment 6 errata-xmlrpc 2017-05-25 17:04:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1333


Note You need to log in before you can comment on or make changes to this bug.