Bug 145087 - Desktop package requiring Bind
Desktop package requiring Bind
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 145212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 04:11 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 09:37:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-01-14 04:11:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
NetworkManager is explicitly specified as a package for Desktop users.
It's not a good idea to force Desktop users to install and run BIND.

Version-Release number of selected component (if applicable):
NetworkManager-0.3.3-1.cvs20050112.1

How reproducible:
Always

Steps to Reproduce:
1. Try to update to the new version
2. Notice it requires caching-name-server which leads to BIND

    

Actual Results:  #rpm -e NetworkManager NetworkManager-gnome

Expected Results:  #rpm -Fvh NetworkManager*

Additional info:
Comment 1 Dan Williams 2005-01-14 09:37:34 EST
Bind is used in a caching-nameserver capability to work around glibc
not noticing changes to /etc/resolv.conf quickly enough.  This is not
a bug.
Comment 2 Dan Williams 2005-01-17 16:14:25 EST
*** Bug 145212 has been marked as a duplicate of this bug. ***
Comment 3 Trond Eivind Glomsrød 2005-01-17 16:27:15 EST
It should be noted that while it may help some corner cases I've never
seen, it breaks a lot of things now - things like "search" and
"domain" from resolv.conf are now completely gone. This breaks
behaviour in local networks.

(in addition to the inherent evilness of having to run bind for this...)
Comment 4 Dan Williams 2005-01-17 16:29:45 EST
True, but overwriting /etc/resolv.conf upon install is something that
caching-nameserver package does, and /etc/resolv.conf should probably
be marked %config in that package, if its not already.

NetworkManager is going to blow away your /etc/resolv.conf _by
design_, so its definitely not a bug in NM.
Comment 5 Dan Williams 2005-01-17 16:32:26 EST
Hmm, caching-nameserver already makes /etc/named.conf %config, so
that's not the issue then.

In any case, this still isn't a bug since NM is designed to take over
name resolution.  Future versions will allow more
options/configuration for name resolution however.
Comment 6 Trond Eivind Glomsrød 2005-01-17 16:46:19 EST
Using standard dhclient will get domain in /etc/resolv.conf correct,
so why use another semi-broken way?
Comment 7 Dan Williams 2005-01-18 09:14:22 EST
Trond,

Could you paste in an example of a "correct" resolv.conf (you can x
out the IP addresses if you like)?  Its probably some DHCP options
that we're just not writing to the resolv.conf file, but I need to
know what those are.

Thanks, Dan
Comment 8 Dan Williams 2005-01-18 09:16:10 EST
Note, everyone, that yes bind is evil and doesn't have an extremely
secure history.

Its only a temporary solution until we can re-work 'lwresd' from the
bind package and glue that with 'nss_lwres' to come up with a
light-weight daemon that will do the same thing, but not be limited as
nscd is right now.  The main thing we need to be able to do is to
direct queries for certain hosts to certain DNS servers, which of
course nscd can't really do right now.

So bind _is_ going away quite soon.
Comment 9 Matthias Saou 2005-01-28 13:23:34 EST
So, bind is gone for NM in FC3, but I still experience a regression :
the local domain that my dhcp server sends isn't searched for hosts.
Using host names like "ftp" doesn't work anymore, whereas it used to
before the bind dependency was introduced.
I've just checked and my /etc/resolv.conf contains the right
nameserver line, but no search line.
Comment 10 Dan Williams 2005-01-28 14:26:45 EST
We'll fix that and make sure that the search name is added.
Comment 11 Dan Williams 2005-01-28 14:27:41 EST
For that RFE, see Bug 145340

Note You need to log in before you can comment on or make changes to this bug.