Bug 145212 - NetworkManager-0.3.3-1.cvs20050112.1.fc3 requires bind
NetworkManager-0.3.3-1.cvs20050112.1.fc3 requires bind
Status: CLOSED DUPLICATE of bug 145087
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 145211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 08:34 EST by Arnaud Abélard
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Abélard 2005-01-15 08:34:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
NetworkManager-0.3.3-1.cvs20050112.1.fc3 from updates requires
caching-nameserver which requires bind.

It's surprising that an update requires new packages to be installed,
especially bind.



Version-Release number of selected component (if applicable):
NetworkManager-0.3.3-1.cvs20050112.1.fc3

How reproducible:
Always

Steps to Reproduce:
install a rpm for NetworkManager < 0.0.3-1
do a yum update 

Actual Results:  Transaction Listing:
  Update: NetworkManager.i386 0:0.3.3-1.cvs20050112.1.fc3
 
Performing the following to resolve dependencies:
  Install: bind.i386 20:9.2.4-2
  Install: caching-nameserver.noarch 0:7.3-3


Expected Results:  the NetworkManager update should not depend on new
packages?

Additional info:
Comment 1 Arnaud Abélard 2005-01-15 09:18:43 EST
*** Bug 145211 has been marked as a duplicate of this bug. ***
Comment 2 Daryll 2005-01-15 13:59:34 EST
Additionally installing the caching nameserver installed a new version
of /etc/resolv.conf overwriting the existing one. That broke name
service on the machine.

I understand that Network Manager requires the ability to do it's own
DNS requests (outside of glibc) but there must be a way to pull in
that client library without installing any name server.
Comment 3 David Hollis 2005-01-15 17:04:06 EST
Name service probably broke after the new resolv.conf was written due
to named not running.  That was one problem I have experienced with
this new change.  The next problem is that if I am on a network where
the client system does not have the ability to perform DNS queries
externally.  In that case, I'm totally screwed.  This happened to me
just the other day at a client that has a wireless 'test' network for
non-trusted folks.  Only port 80 and some IM ports are allowed out to
the net so I had to dig into my /var/lib/dhcp/dhclient-eth1.leases
file to see what DNS servers where given to me so I could manually
edit my /etc/resolv.conf.  So far, this new change has caused me
considerably more problems than it has resolved.
Comment 4 Trond Eivind Glomsrød 2005-01-17 05:23:55 EST
It also doesn't seem to understand "search" etc from old resolv.conf. 
I didn't notice any breakage before starting to use bind, actually :)
(other than never rememembering the wireless keys and popping up twice
occasionally, something which hasn't happened since the update)
Comment 5 Dan Williams 2005-01-17 16:14:22 EST
This is a dupe.

*** This bug has been marked as a duplicate of 145087 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:07:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.