Bug 1450995 - Fedora 25/26 - Firefox 53 - Arm build failure
Summary: Fedora 25/26 - Firefox 53 - Arm build failure
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-15 14:23 UTC by Martin Stransky
Modified: 2017-05-30 11:43 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1443938
Environment:
Last Closed: 2017-05-30 11:43:18 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1337988 None None None 2017-05-30 11:43 UTC

Description Martin Stransky 2017-05-15 14:23:25 UTC
Crash @setObejctNoCheck on ARM while creating startup cache:

We can't build Firefox on Fedora 25/24 due to upstream bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1337988

Comment 1 Jeremy Linton 2017-05-23 21:57:52 UTC
I just tested pbrobinson's koji build https://koji.fedoraproject.org/koji/taskinfo?taskID=19707766 based on ndufresne's patch here:

https://paste.fedoraproject.org/paste/9PPK3VEl4N4~OqB5KbDkHV5M1UNdIGYhyRLivL9gydE=

and FF 53.0.2 is working on my machine.

Comment 2 Jeremy Linton 2017-05-23 22:01:09 UTC
(tested aarch64 not arm64)

Comment 3 Martin Stransky 2017-05-24 06:36:17 UTC
Thanks, I'll test the patch.

Anyway, armv7hl is building now but it's only because we have a workaround for mozbz#1337988.


Note You need to log in before you can comment on or make changes to this bug.