Bug 145141 - iscsi-ls -l doesn't enumerate the devices correctly.
iscsi-ls -l doesn't enumerate the devices correctly.
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: AJ Lewis
Brock Organ
: 146812 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2005-01-14 13:38 EST by Wayne Berthiaume
Modified: 2008-04-07 00:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-25 12:27:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Initial patch to fix the > 26 lun bug (779 bytes, patch)
2005-02-15 12:53 EST, AJ Lewis
no flags Details | Diff

  None (edit)
Description Wayne Berthiaume 2005-01-14 13:38:52 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Server has three NICs, two are connected to the VLAN on two seperate 
subnets for iSCSI targets. There are two iSCSI arrays on the VLAN 
with two connections each one to one subnet and one to the other 
subnet. Therefore this is a multipathing configuration. There are 34 
LUNs assigned between the two storgae arrays to the one server. 
Therefore, the server sees two paths to each LUN for a yield of 68 
LUNs seen by the OS.

1.Installed RHEL U3 (lk 2.4.21-27.EL) updated to lk 2.4.21-27.0.1.EL
2.set up iSCSI with defaults in the iscsi.conf file
3.From a root prompt issue iscsi-ls -l
Actual results:
1) Only shows /dev/sda thru sdz all other LUNs are listed but 
no /dev/sd psuedo device names.
2) The enumeration is not correct. iscsi-ls() associates the psuedo 
device names incorrectly. Associating them with the first 26 LUNs in 
order that they are listed by iscsi-ls() output.
Expected results:
iscsi-ls() should report all the devices that are attached to an 
iscsi initiator and report them according to the initiator they are 
connected to correctly.

Additional info:
Comment 1 Wayne Berthiaume 2005-01-14 13:48:20 EST
Sorry... This is RHEL 3.0 U4.
Comment 3 Tom Coughlan 2005-02-01 15:25:31 EST
*** Bug 146812 has been marked as a duplicate of this bug. ***
Comment 4 AJ Lewis 2005-02-15 12:38:37 EST
I'm a bit confused about what you mean in item 2.  Could you provide the
erroneous output for me?
Comment 5 AJ Lewis 2005-02-15 12:53:36 EST
Created attachment 111094 [details]
Initial patch to fix the > 26 lun bug

Here's an initial stab at a fix for this one:
allow the device name to be 4 characters, but verify the 4th character is an 
alphabetic character so we don't get /dev/sda1 in the output

This should catch the double letter sdxx devices, but avoid the sdx1 partitions
Comment 6 AJ Lewis 2005-02-16 13:19:18 EST
There is an i386 rpm at
http://people.redhat.com/alewis/rpms/iscsi-initiator-utils-3.6.2-6.i386.rpm that
includes the patch from comment #5.  Please try this and see if it fixes the
problem.  Note that this RPM is unsupported.
Comment 7 Wayne Berthiaume 2005-02-17 18:44:39 EST
I was unable to install the rpm. I tried -Uvh and it complained of a conflict 
with the original iscsi init script. To install the package I erased the 
original package then installed, with -ivh, the new package. I receive this 
error when I try to start the iscsi driver with a "service iscsi start" command:

Feb 17 18:25:59 l82bi121 iscsid[4615]: version 3.6.2 (27-Sep-2004)
Feb 17 18:25:59 l82bi121 iscsid[4615]: failed to check INBP boot status while da
emon starting errno = 22
Feb 17 18:25:59 l82bi121 iscsid[4615]: INBP ioctl not implemented in the install
ed iSCSI driver version
Feb 17 18:25:59 l82bi121 kernel: ioctl32(iscsid:4615): Unknown cmd fd(3) cmd(004
7030b){00} arg(08064520) on /dev/iscsictl
Feb 17 18:26:04 l82bi121 iscsi:  failed
Comment 8 AJ Lewis 2005-02-22 12:34:13 EST
What is the kernel version you are using?
Comment 9 Wayne Berthiaume 2005-02-28 11:06:02 EST
The kernel is 2.4.21.-27.EL SMP x86_64.
Comment 10 AJ Lewis 2005-02-28 11:08:38 EST
Well, that explains it - the rpm i posted on my peoples page is for x86, not
x86_64!  I'll put an x86_64 rpm up as well.
Comment 12 Wayne Berthiaume 2005-02-28 17:41:10 EST
I've downloaded it and will update with a new status.
Comment 13 AJ Lewis 2005-03-07 10:08:01 EST
Any status updates from people trying this?
Comment 14 Wayne Berthiaume 2005-03-28 13:49:52 EST
AJ, I've tested the -i386 package you posted and it worked properly. 
Thank you.
Comment 15 Heather Conway 2005-04-08 11:24:55 EDT
Testing is in process 
Comment 16 Wayne Berthiaume 2005-04-08 12:19:02 EDT
Hi AJ.
    I've tested the RHEL U5 beta for this issue and it appears to be corrected.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.