Bug 146812 - iscsi-ls does not display device information for devices > /dev/sdz
iscsi-ls does not display device information for devices > /dev/sdz
Status: CLOSED DUPLICATE of bug 145141
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: AJ Lewis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 15:16 EST by Dave Wysochanski
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2005-02-01 15:16:07 EST
Description of problem:
If iSCSI devices are mapped to /dev/sd* entries greater than /dev/sdz,
the device and mode page data is not displayed for these LUNs.  This
is really great info to have for all the LUNs.

Version-Release number of selected component (if applicable):
iscsi-initiator-utils-3.6.2-4

How reproducible:
- every time

Steps to Reproduce:
1. Map enough iSCSI LUNs on the host so that at least one LUN gets
mapped above /dev/sdz
2. issue "iscsi-ls -l" command
3. Note the displayed info for LUNs > /dev/sdz differs for <= /dev/sdz
  
Actual results:
Limited "iscsi-ls -l" output for devices > /dev/sdz

Expected results:
All /dev/sd* entries should display, up to the limit of the iSCSI
driver and/or kernel limits.


Additional info:
Found at least one part of the problem - in the below snippit of code
(probably not hard to fix).

_get_devs_from_proc() contains this comment/code:


        /* FIXME: If there are > 26 scsi devices, we won't get those
           that have 2 letters in their names */
        if(!isalpha(name[0]) || strncmp(name, "sd", 2) ||
(strlen(name) > 3)){
            memset(name, 0, sizeof(name));
            curproc = tmpproc + 1;
            memset(proc_line, 0, sizeof(proc_line));
            continue;
        }
Comment 1 Tom Coughlan 2005-02-01 15:25:24 EST

*** This bug has been marked as a duplicate of 145141 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.