Bug 145178 - Parallel port not detected in 2.6.10 kernels
Parallel port not detected in 2.6.10 kernels
Status: CLOSED DUPLICATE of bug 145151
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 19:13 EST by Michael J. Chudobiak
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 23:55:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2005-01-14 19:13:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
My HP LaserJet 2100 printer stopped working after the kernel was
updated from 2.6.9 versions to 2.6.10. CUPS can not locate the
parallel port (/dev/lp0).

Selecting 2.6.10-1.741_FC3 or 2.6.10-1.737_FC3 from grub, and running
"dmesg | grep lp" gives:

lp: driver loaded but no devices found

Modules linked in: parport_pc lp parport autofs4 ipt_state ipt_REJECT
ipt_limit ipt_LOG ip_conntrack_ftp ip_conntrack iptable_filter
ip_tables microcode dm_mod video button battery ac md5 ipv6 uhci_hcd
ehci_hcd i2c_i801 i2c_core snd_intel8x0 snd_ac97_codec snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc tg3
floppy ext3 jbd ata_piix libata sd_mod scsi_mod 

Selecting 2.6.9-1.724_FC3 from grub, and running "dmesg | grep lp" gives:

lp0: using parport0 (polling).
lp0: console ready 

and the printer works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select a 2.6.9 kernel from grub.
2. Check that a parallel port is detected using dmesg - for me, it is.
3. Select a 2.6.10 kernel from grub.
4. See if a parallel port is detected using dmesg - for me, it isn't.
    

Additional info:
Comment 1 Michael J. Chudobiak 2005-01-14 19:20:56 EST
Sorry, forgot the system details:

Hewlett-Packard D330 tower, 2.66GHz Intel Pentium 4 processor, 768 MB RAM

Last working, printing installed kernel was (uname -a):
Linux strawberry 2.6.9-1.724_FC3 #1 Sun Jan 2 15:43:49 EST 2005 i686
i686 i386 GNU/Linux
Comment 2 Michael J. Chudobiak 2005-01-14 20:17:57 EST
Additional clues - dmesg shows some differences for parport - on the
working 2.6.9-1.724_FC3:

[root@strawberry mjc]# dmesg | grep parport
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport0: irq 7 detected
parport0: faking semi-colon
parport0: Printer, Hewlett-Packard HP LaserJet 2100 Series
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport0: irq 7 detected
parport0: faking semi-colon
parport0: Printer, Hewlett-Packard HP LaserJet 2100 Series
lp0: using parport0 (polling).


and on the problematic 2.6.10-1.741_FC3:

par[root@strawberry mjc]# dmesg | grep parport
port: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP,TRISTATE]
parport0: faking semi-colon
parport0: Printer, Hewlett-Packard HP LaserJet 2100 Series
parport: PnPBIOS parport detected.
Modules linked in: parport_pc lp parport autofs4 ipt_state ipt_REJECT
ipt_limit ipt_LOG ip_conntrack_ftp ip_conntrack iptable_filter
ip_tables microcode dm_mod video button battery ac md5 ipv6 uhci_hcd
ehci_hcd i2c_i801 i2c_core snd_intel8x0 snd_ac97_codec snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc tg3
floppy ext3 jbd ata_piix libata sd_mod scsi_mod


I don't see any option for enabling/disabling PNP in the bios.
Comment 3 Dave Jones 2005-01-14 23:55:52 EST

*** This bug has been marked as a duplicate of 145151 ***

Note You need to log in before you can comment on or make changes to this bug.