Bug 145151 - parport disabled in kernels 2.6.10-1.8_FC2 and 2.6.10-1.9_FC2
parport disabled in kernels 2.6.10-1.8_FC2 and 2.6.10-1.9_FC2
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 145178 145230 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 15:35 EST by Paul Heinlein
Modified: 2015-01-04 17:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 09:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Heinlein 2005-01-14 15:35:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Using kernels kernels 2.6.10-1.8_FC2 and 2.6.10-1.9_FC2, I'm unable to
address my PC-style parallel port at 0x378, irq 7. I get messages that
the device has been disabled, e.g.,

Jan 13 05:29:26 x kernel: parport: PnPBIOS parport detected.
Jan 13 05:29:26 x kernel: parport0: PC-style at 0x378, irq 7 [PCSPP]
[...]
Jan 13 05:29:27 x kernel: pnp: Device 00:04 activated.
Jan 13 05:29:27 x kernel: parport: PnPBIOS parport detected.
Jan 13 05:29:27 x kernel: pnp: Device 00:04 disabled.
Jan 13 05:29:27 x kernel: lp: driver loaded but no devices found

The upshot is that printing via the parallel port is broken.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.10-1.9_FC2

How reproducible:
Always

Steps to Reproduce:
Happens every time at boot.

Additional info:

I tried removing the lp, parport_pc, and parport modules and loading
them with different parameters, none of which worked.

I also tried booting the kernel with "pnpbios=no"; no dice.
Comment 1 Dave Jones 2005-01-14 23:55:59 EST
*** Bug 145178 has been marked as a duplicate of this bug. ***
Comment 2 Paul Bolle 2005-01-15 09:32:02 EST
I hope I'm allowed some "me too" bugzilla-spam: I noticed printing via
parallel port didn't seem to work. On my first investigation hwbrowser
segfaulted.

Summary: this seems to effect 2.6.10-1.741_FC3 too.

Some info:
[~]$ uname -r
2.6.10-1.741_FC3

[~]$ PYTHONPATH=/usr/share/hwbrowser/ /usr/bin/python
/usr/share/hwbrowser/DeviceList.py
Segmentation fault

[~]$ tail -n 10 hwbrowser.strace
close(20)                               = 0
munmap(0xb7b9a000, 4096)                = 0
open("/proc/sys/dev/parport",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 20
fstat64(20, {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
fcntl64(20, F_SETFD, FD_CLOEXEC)        = 0
getdents64(20, /* 4 entries */, 1024)   = 112
open("/proc/sys/dev/parport/default/autoprobe", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/proc/sys/dev/parport/parport0/autoprobe", O_RDONLY) = 21
read(21,  <unfinished ...>
+++ killed by SIGSEGV +++

[~]$ less /proc/sys/dev/parport/parport0/autoprobe
Segmentation fault
Comment 3 Andre Robatino 2005-01-15 14:11:30 EST
  I filed bug #145230 for FC3 before finding this bug report.  In it I
gave a workaround to this problem from Fedora Forum.
Comment 4 Michael J. Chudobiak 2005-01-16 17:45:20 EST
I can confirm that my problems (duplicate bug #145178) were fixed
after adding:

alias parport_lowlevel parport_pc
options parport_pc io=0x378,0x278 irq=7,auto

to the end of /etc/modprobe.conf (2.6.10-1.741_FC3), as suggested above.

Comment 5 Dave Jones 2005-01-16 23:33:26 EST
*** Bug 145230 has been marked as a duplicate of this bug. ***
Comment 6 Andre Robatino 2005-02-03 05:37:23 EST
  This bug still exists in kernel-2.6.10-1.760_FC3 for FC3 (and is
still fixed by adding the above two lines to modprobe.conf).
Comment 7 Andre Robatino 2005-02-19 00:57:16 EST
  Ditto for kernel-2.6.10-1.766_FC3.
Comment 8 Paul Bolle 2005-02-22 19:44:17 EST
Well, I couldn't reproduce this problem with 2.6.10-1.766_FC3.

This might be because I'm running that kernel on an AMD athlon. I was
running 2.6.10-1.741_FC3 on an Intel box. (I haven't checked
2.6.10-1.741_FC3 on the athlon.)
Comment 9 Andre Robatino 2005-02-23 02:23:11 EST
  I have two machines, a SYSMAR 561 with a Duron CPU, which isn't
affected, and an old Emachines 333cs with a Trigem Delhi3 MB and a
Cyrix M2 CPU, which is.  My father has an Emachines 300k which is
identical except that the CPU is an AMD K6-2, and it's also affected.
 The printer is the same in all cases, so the only thing that seems to
matter is the MB.  I posted dmesg output in bug #145230, which hasn't
changed noticeably in the latest kernels.
Comment 10 Andre Robatino 2005-02-26 23:02:45 EST
  Bug #145227 appears to be a dupe of this one (the dmesg output from
bug #145230 is the same as the kernel output from that one).  I tried
to add a comment to #145227 but got an error message

 You tried to change the Assignee field from davej@redhat.com to no
value, but only the owner or submitter of the bug, or a sufficiently
empowered user, may change that field.

  Could someone explain what I'm doing wrong, if anything?
Comment 11 Andre Robatino 2005-03-05 16:40:43 EST
  kernel-2.6.10-1.770_FC3 is still affected.  I was able to add a
comment to bug #145227 by clicking on the above link.  On the other
hand, some common ways of accessing this bug, such as going to the
Bugzilla home page and entering the bug number, lead to the page

https://bugzilla.redhat.com/beta/show_bug.cgi?id=145227

in which it's impossible to make changes.  
Comment 12 Igor 2005-03-23 05:52:19 EST
I have the same problem with an old IBM ThinkPad 600E laptop, FC3 installed.
Tried different kernels from the one that came with the distribution (2.6.9) to
the latest kernel-2.6.10-1.770_FC3. 

Without the two lines in /etc/modprobe.conf mentioned above, dmesg just prints
the infamous "lp: driver loaded but no devices found".

After adding the lines

alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=none

(also tried different io adresses, irqs, etc - of course the same as those set
in windows through thinkpad configurator) - same result:

dmesg in all cases says something like

parport 0x378 (WARNING): CTR: wrote 0x0c, read 0xff
parport 0x378 (WARNING): DATA: wrote 0xaa, read 0xff
parport 0x378: You gave this address, but there is probably no parallel port
there!
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
lp0: using parport0 (polling).
lp0: console ready

Any attempt to print causes an error message "printer not found".

Any help is very welcome!
Comment 13 Igor 2005-03-23 08:18:00 EST
Oops, sorry, an attempt to access the parallel port results in the error message
"parallel port not found". Needless to say, the port is working OK in windows XP.
Comment 14 Andre Robatino 2005-03-23 13:05:12 EST
  In my case, the above warning messages only happened when I used the two lines
with two arguments each for io and irq.  Since I only have one parallel port, it
was correctly informing me that there was nothing at 0x278.  The printer still
worked - the warning was harmless.  Getting rid of the second arguments made the
warning go away.  I suspect you're not giving the correct io address for your
parallel port.
Comment 15 Igor 2005-03-24 05:42:46 EST
> I suspect you're not giving the correct io address for your
> parallel port.

I DO. I set it in windows, check in windows that the port works ok, then reboot
to Linux, use the same address - no dice. Disables any advanced printer modes
like ecp, epp - same result. I also listed all possible io addresses in one line
  - io=0x3bc,0x378,0x278 - ALL addresses resulted in the same message "You gave
this address, but there is probably no parallel port there!".
Comment 16 Andre Robatino 2005-03-24 10:50:21 EST
  After the "lp: driver loaded but no devices found" do you get a call trace
very similar to

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=109822

(the standard call trace for this bug, using the 737 kernel, the first FC3
kernel for which most people started having this problem)?  If yours is
different, could you post it as an attachment?
Comment 17 Igor 2005-03-25 09:45:00 EST
There is no call trace in the output of dmesg in 2.6.10-1.737_FC3 or any other
kernel version - nothing resembling the example you gave. The part of dmesg
output arount the line "lp: driver loaded but no devices found" is:

...
eth0: NE2000 Compatible: io 0x300, irq 3, hw_addr 00:80:C8:85:AF:3C
ip_tables: (C) 2000-2002 Netfilter core team
lp: driver loaded but no devices found
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0360380(lo)
IPv6 over IPv4 tunneling driver
divert: not allocating divert_blk for non-ethernet device sit0

lsmod lists the modules:
Module                  Size  Used by
sd_mod                 17089  0
usb_storage            61449  0
scsi_mod              120897  2 sd_mod,usb_storage
md5                     4033  1
ipv6                  230273  8
parport_pc             26501  0
lp                     12077  0
parport                36617  2 parport_pc,lp
autofs4                22981  0
sunrpc                154149  1
pcnet_cs               18169  1
8390                   11845  1 pcnet_cs
pcmcia                 20805  5 pcnet_cs
vfat                   12481  1
fat                    39649  1 vfat
dm_mod                 55509  0
yenta_socket           19137  1
pcmcia_core            50817  3 pcnet_cs,pcmcia,yenta_socket
uhci_hcd               31321  0
i2c_piix4               8273  0
i2c_core               20801  1 i2c_piix4
floppy                 57329  0
ext3                  116041  1
jbd                    68185  1 ext3

An attempt to print results in the error message "parallel port not responding".
Do you need the whole dmesg output?

Thanks for your help.
Comment 18 Andre Robatino 2005-03-25 17:03:35 EST
  It sounds like your bug, even if it has the same result, is a different one. 
Have you ever had any other Linux distros besides FC3 installed on this laptop
that did detect the parallel port properly?  If not, you could get hold of a
bootable CD for Knoppix or some other distro and try that.  Or you could try a
boot CD for an earlier Fedora version just to check for the error.
Comment 19 Dave Jones 2005-04-16 02:10:34 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 20 Tim Waugh 2005-04-17 07:28:40 EDT
Dave, this was never fixed.
Comment 21 Andre Robatino 2005-04-17 13:02:00 EDT
  In bug #155002, which is a dupe of this one, it's reported that in the latest
2.6.11 kernel, this is still broken, though the call trace no longer appears
after the line

lp: driver loaded but no devices found

so maybe comment #12 above is an example of the same bug after all (though for
him it appeared for all FC3 kernels, not just the later ones).
Comment 22 Craig Cook 2005-04-18 08:48:45 EDT
Correction, this is not an issue in these kernels:
2.6.9-1.667
2.6.9-1.724_FC3

But, fails to detect printer if using these kernels
2.6.10-1.741_FC3
2.6.10-1.737_FC3
2.6.10-1.766_FC3
2.6.10-1.770_FC3
2.6.11-1.14_FC3

Also, my soundcard fails to send output to my earphone jack in the 2.6.10, and
2.6.11 kernels, so something else is wrong.  The modprobe.conf edit does work
for 2.6.11 for the parallel port, but not the soundcard.  bug #155002 contains
detailed output listings.
Comment 23 Dave Jones 2005-10-06 00:28:52 EDT
did the 2.6.12 based errata improve the situation any ?
Comment 24 John Thacker 2006-05-04 09:16:09 EDT
No response, closing.

Note You need to log in before you can comment on or make changes to this bug.