Bug 145230 - parallel port printing broken by 737 and 741 kernels
parallel port printing broken by 737 and 741 kernels
Status: CLOSED DUPLICATE of bug 145151
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 12:56 EST by Andre Robatino
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-16 23:33:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output with call trace for 737 kernel (12.94 KB, text/plain)
2005-01-15 12:57 EST, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2005-01-15 12:56:16 EST
Description of problem:
  Parallel port printing is broken by the 737 and 741 kernels.  There
is a call trace during bootup indicating that the kernel can't find
the printer.  Print jobs are queued but not printed.  Adding the two lines

alias parport_lowlevel parport_pc
options parport_pc io=0x378,0x278 irq=7,auto

to /etc/modprobe.conf gets rid of the call trace and the printer will
then work.  Below I attach the dmesg output for the 737 kernel (the
problem with 741 is similar).

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3
kernel-2.6.10-1.741_FC3

How reproducible:
always

Steps to Reproduce:
1.  Boot up in 737 or 741 with a parallel port printer connected.
  
Actual results:
  Call trace during bootup.  Printing doesn't work.

Expected results:
  No call trace.  Printing should work.

Additional info:
  Fix comes from Fedora Forum:

http://www.fedoraforum.org/forum/showthread.php?t=31844
Comment 1 Andre Robatino 2005-01-15 12:57:54 EST
Created attachment 109822 [details]
dmesg output with call trace for 737 kernel
Comment 2 Andre Robatino 2005-01-15 13:11:04 EST
  I forgot to mention that this happens to my father with a 6-year old
Emachine, but not to me with a Microtel SYSMAR561, even though our
printers are identical (and both connected to /dev/lp0).
Comment 3 Dave Jones 2005-01-16 23:33:14 EST

*** This bug has been marked as a duplicate of 145151 ***

Note You need to log in before you can comment on or make changes to this bug.