Bug 14531 - RPM-4.0 --excludedocs
RPM-4.0 --excludedocs
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 11:16 EDT by Art Boulatov
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 08:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Art Boulatov 2000-07-24 11:16:26 EDT
With the --excludedocs install option RPM-4.0  creates empty
%{name}-%{version} dirs under %{_defaultdocdir}:

rpm -i --excludedocs -vv sysvinit-2.78-1art.i686.rpm:

> D:    file: /usr/share/doc/sysvinit-2.78 action: create
> D:    file: /usr/share/doc/sysvinit-2.78/HISTORY action: skipnstate
> D:    file: /usr/share/doc/sysvinit-2.78/Install action: skipnstate
> D:    file: /usr/share/man/en/man1/last.1.bz2 action: skipnstate

There should be a 'skipnstate' instead of 'create' in the first line.
Comment 1 Jeff Johnson 2000-07-31 11:19:15 EDT
You're correct, this will be fixed in rpm-4.1.
Comment 2 Jeff Johnson 2000-09-16 10:43:26 EDT
This issue depends on whether a directory can/should have the attribute %doc.
The current
implementation of file attributes in rpm forbids directories to have either %doc
or %config
attributes because directories may contain files other than documentation (and
so should not
be excluded with --excludedocs). Identifying whether a directory has contents
other than
documentation is non-local and expensive (read: it's not just a single bit
test).

I've marked the code, but I don't believe that the implementation is justified
at this time.
Comment 3 Jeff Johnson 2001-04-03 09:45:27 EDT
Fixed in rpm CVS, should be in rpm-4.0.3-0.4 and later.

Note You need to log in before you can comment on or make changes to this bug.