Bug 145404 - NetworkManager blocks current update to wireless-tools
NetworkManager blocks current update to wireless-tools
Status: CLOSED DUPLICATE of bug 145395
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 20:02 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-01-17 20:02:35 EST
Description of problem:

'rpm -qR NetworkManager' shows 'wireless-tools >= 27' but also
'libiw.so.27'.  This is causing trouble as then current update
'wireless-tools-28-0.pre4.1.fc3' provides libiw.so.28 and yum
attempts to pull wireless-tools - 1:27-0.pre25.2 "as update for 
NetworkManager" (this is from a yum debug output) even if
wireless-tools-27-0.pre25.3 are currently installed.  That action,
not so surprisingly, fails and we have a dependency problem until
NetworkManager will get the next update.

yum, alas, does not skip automatically through such sore spots
when simply asked 'update' or 'upgrade'.

Version-Release number of selected component (if applicable):
NetworkManager-0.3.3-1.cvs20050112.1.fc3
Comment 1 David Martin 2005-01-17 20:41:47 EST
I have the same problem. Here's the error from up2date. Seems like
kdenetwork depends on libiw.so.27 as well:


There was a package dependency problem.  The message was:

Unresolvable chain of dependencies:
NetworkManager  0.3.3-1.cvs20050112.1.fc requires libiw.so.27
kdenetwork  3.3.1-1                      requires libiw.so.27

Please modify your package selections and try again.
Comment 2 Michal Jaegermann 2005-01-17 23:10:40 EST
Oh, I happen not to have kdenetwork installed so I missed that.
Does this dependency on libiw.so has to be that specific?
This will cause headaches every time wireless-tools version
will get bumped up.
Comment 3 Dan Williams 2005-01-18 09:18:30 EST

*** This bug has been marked as a duplicate of 145395 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.