Bug 145395 - NetworkManager RPM requires wireless-tools >= 27 and libiw.so.27
NetworkManager RPM requires wireless-tools >= 27 and libiw.so.27
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 145404 145415 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 18:07 EST by Matthew Saltzman
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 16:49:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2005-01-17 18:07:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
An update to wireless-tools-28-0.pre4.1.fc3 was just released, but it
won't install alongside the above version of NetworkManager due to
this dependency.

Version-Release number of selected component (if applicable):
NetworkManager-0.3.3-1.cvs20050112.1.fc

How reproducible:
Always

Steps to Reproduce:
1. Update to latest wireless-tools with latest NetworkManager installed
or
2. Update to latest wireless-tools and attempt to install latest
NetworkManager

3.
    

Actual Results:  Violated dependency.

Expected Results:  Both packages should install together (and work,
but that's a different issue).

Additional info:
Comment 1 Jim Cornette 2005-01-17 20:37:56 EST
Running up2date results in this error after dep resolving is attempted


There was a package dependency problem.  The message was:

Unresolvable chain of dependencies:
NetworkManager  0.3.3-1.cvs20050112.1.fc requires libiw.so.27
kdenetwork  3.3.1-1                      requires libiw.so.27

Please modify your package selections and try again.
Comment 2 Jim Cornette 2005-01-17 20:39:22 EST
wireless tools is the package that is failing to be installed.
Comment 3 Matthew Saltzman 2005-01-17 20:46:19 EST
Looks like there needs to be a bug filed agains kdenetwork also.  

# rpm -q --redhatrequires libiw.so.27
NetworkManager-0.3.1-3
kdenetwork-3.3.0-5

These will both need to be updated to install them with the latest
wireless-tools.
Comment 4 Dan Williams 2005-01-18 09:18:37 EST
*** Bug 145404 has been marked as a duplicate of this bug. ***
Comment 5 Dan Williams 2005-01-18 09:20:57 EST
*** Bug 145415 has been marked as a duplicate of this bug. ***
Comment 6 Dan Williams 2005-01-18 09:49:11 EST
NetworkManager is being rebuilt against libiw.so.28 and should be out by tomorrow.
Comment 9 miji piji 2005-01-24 20:55:11 EST
I hope I'm not missing something, but for me the new NetworkManager
still doen't work...


Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package NetworkManager.i386 0:0.3.3-1.cvs20050119.2.fc3 set to be
installed--> Running transaction check
--> Processing Dependency: libiw.so.27 for package: NetworkManager
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for wireless-tools to pack into transaction set.
wireless-tools-27-0.pre25 100% |=========================| 7.4 kB    00:00
---> Package wireless-tools.i386 1:27-0.pre25.3 set to be updated
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Install: NetworkManager.i386 0:0.3.3-1.cvs20050119.2.fc3

Performing the following to resolve dependencies:
  Update: wireless-tools.i386 1:27-0.pre25.3
Is this ok [y/N]: n
Comment 10 Dan Williams 2005-01-24 21:00:20 EST
miji piji:

Why didn't you answer "y" when it asked to upgrade wireless-tools? 
That's the required verison for NetworkManager currently...
Comment 11 Matthew Saltzman 2005-01-24 21:29:22 EST
But the latest FC3 version of wireless-tools is
wireless-tools-28-0.pre4.1.fc3.  That's what led me to file the bug in
the first place.

BTW, using up2date, I don't get a chance to do anything to
wireless-tools if I am running the latest:

[mjs]$ up2date NetworkManager
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-3
using mirror: http://ftp.uni-koeln.de/fedora/3/i386/os/
http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc3
using mirror:
http://www.las.ic.unicamp.br/pub/fedora/linux/core/updates/3/i386

Fetching Obsoletes list for channel: fedora-core-3...

Fetching Obsoletes list for channel: updates-released-fc3...

Fetching rpm headers...
########################################

Name                            Version        Rel
--------------------------------------------------
NetworkManager                  0.3.3  1.cvs20050119.2.fc3i386


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
NetworkManager  0.3.3-1.cvs20050119.2.fc requires libiw.so.27

[mjs]$ rpm -q wireless-tools
wireless-tools-28-0.pre4.1.fc3
Comment 12 Matthew Saltzman 2005-01-24 23:15:21 EST
Re: Comment #11.

Never mind... I see the confusion about the latest wireless-tools.
Comment 13 Dan Williams 2005-01-25 07:49:50 EST
Technically, the wireless-tools-28 update got pulled from FC3, but is
still in devel/rawhide.  If its installed on your system you'll
probably have to rpm -e wireless-tools --nodeps, and then 'yum install
wireless-tools' again.  Sorry for the confusion...

Dan
Comment 14 miji piji 2005-01-25 12:14:33 EST
it looks more like this is a yum problem.

have you see bug 144376 ?

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144376

cheers
Comment 15 miji piji 2005-01-25 12:26:12 EST
Re: Comment #10

well I did not answer yes because when i do that there is conflicts
with the installed version of wireless-tools. which is wireless-tools-28.

You said that NetworkManager was being rebuilt against libiw.so.28. is
this still true? Because I guess this would solve the problem, or not?

miji
Comment 16 Matthew Saltzman 2005-01-25 15:31:02 EST
Re: Comment 15:  See comment #13.  Your version of wireless-tools is
newer than the official released version.  That was my problem and why
this bug is here.  wireless-tools-28 was removed after you and I
updated to it and replaced by a later wireless-tools-27.  If you
downgrade your wireless-tools to the current release, NetworkManager
will install.

Re: Comment 14: There *is* a Yum problem that was revealed by this
particular dependency chain, but this bug is here because the
dependency chain itself was a problem when wireless-tools-28 appeared
to be the current release.  People couldn't upgrade to
wireless-tools-28 if NetworkManager was installed and couldn't install
NetworkManager if wireless-tools-28 was installed.

The particular conflict is moot now, but the possibility of a conflict
in the future is an issue.  If wireless-tools is updated,
NetworkManager must be updated with it.
Comment 17 miji piji 2005-01-25 16:56:50 EST
Thanks for this clear explanation. everything went back to normal now.

miji
Comment 18 Dan Williams 2005-01-29 16:49:04 EST
Should be fixed by now?
Comment 19 Matthew Saltzman 2005-01-29 17:51:31 EST
Well, the Rawhide version requires libiw.so.28, and wireless-tools-28
is  in Rawhide, but there are some other dependencies in NM now that
prevent it from being updated easily (notably dbus=0.23).  So I can't
try that version yet.

But the downgrade of wireless-tools to 27 in Updates solves the
immediate problem.

Note You need to log in before you can comment on or make changes to this bug.