Bug 14541 - Booting jams
Booting jams
Status: CLOSED DUPLICATE of bug 16229
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 15:03 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-20 10:45:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-07-24 15:03:47 EDT
I have a problem while bootin installed system.

Installin seems to go allright but when i boot up at first time system 
hangs and says: Kernel panic - attempted to kill the idle disk
                In swapper task - not syncing


My hardware:   AMD K7 Duron 600Mhz
               MSI K7T Pro mainboard
               13Gt / Ide
Comment 1 Need Real Name 2000-08-19 19:40:16 EDT
I have the same mother board and CPU, and also the same problem. This is what it
looks like (I may have typed something wrong when looking at the screen and
typing it down):

Memory: 127852 k/131008k available (1060 kernel code, 416k reserved, 1616 data,
64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cach hash table entries : 32768 (order 5, 128k)
VFS: Diskquotas version dquot_6.4.0 initialized
L1 I Cache: 64K  L1 D Cache: 64K
L2 Cache: 1K
CPU:	AMD AMD Durnon(tm) Processor stepping 00
Enabling estended fast FTP save and restore...done.
Disabling CPUID Serial number...general protection fault: 0000
CPU:	0
EIP:	0010:[<c023400f4>]
EFLAGS:	00010282
eax: 00000020	ebx: 07c3d1d0	ecx: 00000119	edx: 00000001
esi: 00098800	edi: c0106000	ebp: 00001000	esp: c0233fc8
ds: 0018   es: 0018    ss: 0018
Process swapper (pid: 0, process nr: 0, stackpage=c0233000)
Stack: c0106000 c02344e2 c02143a0 c01d7d0b c02143a0 c0234c7b 07c3bd1d0 07c3d1d0
          07c3d1d0 c03b2e30 c7ff0000 00000000 c0214460 c0100175
Call Trace: [<c0106000>] [<c01d7d0b>] [<c0100175>]
Code: 0f 32 0d 00 00 20 00 0f 30 68 21 78 1d c0 e8 27 fd ed ff 83
Kernel panic: Attempted to kill dhe idle task!
In swapper task - not syncing

I may mention that Storm linux can be installed without problems on the same
system.

More of my HW configuration:
Motherboard: MSI Socket A VIAKT133 ATX K7T-PRO Duron
CPU: AMD Socket A Duron 3DNOW! 600MHz
RAM: 128MB PC133 168-Pin
Videocard: ATI AGP 3D Changer 8MB RageIIC
Harddisc: Western Digital ATA-66 15300MB AWD153BA

Hallvard Paulsen, Bxmlo, Norway
Comment 2 Need Real Name 2000-08-20 10:45:26 EDT
I think I have a workaround:

1. Boot form CD-ROM and, Install as usual (if you want to use multiple
partitions, you may temporarialy just use a / partition large enough to hold a
minimal system, many paritions make this workaround more difficult)

2. Boot CD-ROM again in rescue mode (lilo: linux rescue)

3. Make a temporary mount point for your intallation, root partion (bash# mkdir
/mnt/root). And mount it (bash# mount /dev/hda5 (in my case) /mnt/root

4. copy the kernel-source rpm to somewhere on the harddisk (bash# cp
/mnt/source/RedHat/RPMS/kernel-source*rpm /mnt/root/home

5. Change root  (/) to your harddisk (bash# chroot /mnt/root)

6. Install kernel source rpm (bash# rpm -i /home/kernel-source*rpm)

7. Change to /usr/src/linux and compile according to the instructions in the
file README

8. (I had to do a secound reboot in order to copy the zImage over to my boot
partition /dev/hda1 because it could not be directely mounted after I compiled)

9 run lilo and so on...

10. Now, if I could just get the built in sound card to work...

Hallvard Paulsen
Comment 3 Trond Eivind Glomsrxd 2000-08-20 14:01:22 EDT

*** This bug has been marked as a duplicate of 16229 ***

Note You need to log in before you can comment on or make changes to this bug.