Bug 14557 - tmpwatch fails to delete directories or documentation is incorrect
Summary: tmpwatch fails to delete directories or documentation is incorrect
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 14930 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-24 21:06 UTC by Kevin Way
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-13 19:58:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Way 2000-07-24 21:06:55 UTC
The text of the tmpwatch man page for option -a implies that tmpwatch's
default behavior is to delete both files and directories.  
	
	-a, --all
              Remove all file types, not just regular  files  and
              directories.

The actual default behavior is to just delete regular files.  Directories
do not get deleted unless -a is specified.

Comment 1 Kevin Way 2000-07-24 21:27:43 UTC
source code comments also indicate that proper behavior is to delete both files
and directories.

#define FLAGS_ALLFILES  (1 << 1)   /* normally just files, dirs are removed */

Comment 2 Derek Tattersall 2000-08-13 19:58:11 UTC
*** Bug 14930 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 2000-09-11 18:50:15 UTC
this was fixed for our forthcoming 7.0 release - empty directories will be
removed.  -a will allow non-regular files such as pipes and sockets to be
removed as well.


Note You need to log in before you can comment on or make changes to this bug.