Bug 14930 - tmpwatch does not remove directories (in default setup)
Summary: tmpwatch does not remove directories (in default setup)
Status: CLOSED DUPLICATE of bug 14557
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-31 21:42 UTC by Aleksey Nogin
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 21:42:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2000-07-31 21:42:56 UTC
This problem existed for as long as tmpwatch was in RedHat distribution.
The problem is that by default tmpwatch uses atime for both files and
directories. But because tmpwatch is ran daily, the atime for directories
is always <= 1day, so it never removes them... I believe that by default,
tmpwatch should use atime for files and mtime for empty directories...

Comment 1 Derek Tattersall 2000-08-13 19:58:13 UTC

*** This bug has been marked as a duplicate of 14557 ***

Comment 2 Derek Tattersall 2000-08-13 19:58:51 UTC
Note:  This is fixed in the rawhide and the beta trees.

Comment 3 Matthew Miller 2005-05-16 17:24:59 UTC
I know this bug is ancient, but it never has seemed to work for me, even after
the year 2000....


Note You need to log in before you can comment on or make changes to this bug.