Bug 1456467 - hp-check shows 'CUPS incompatible or not running' even if CUPS is running
Summary: hp-check shows 'CUPS incompatible or not running' even if CUPS is running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1456463
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-29 12:52 UTC by Zdenek Dohnal
Modified: 2017-06-09 19:15 UTC (History)
5 users (show)

Fixed In Version: hplip-3.17.4-2.fc24 hplip-3.17.4-2.fc25 hplip-3.17.4-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1456463
Environment:
Last Closed: 2017-06-08 06:52:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Zdenek Dohnal 2017-05-29 12:52:45 UTC
+++ This bug was initially created as a clone of Bug #1456463 +++

Description of problem:
When hp-check is run, output says 'CUPS incompatible or not running', even if CUPS is running. This is caused by using 'cups-config --version' command in check.py script. This cups-config command is in cups-devel package, which isn't installed with main package.
This hp-check message is misleading and it should be corrected.

Version-Release number of selected component (if applicable):
cups-1.6.3-26

How reproducible:
Always, when cups-devel isn't installed

Steps to Reproduce:
1. install hplip-gui
2. $ hp-check
3.

Actual results:
Message about 'CUPS incompatible or not running'

Expected results:
If CUPS is installed, it should show version and OK

Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2017-05-29 08:50:56 EDT ---

Since this bug report was entered in Red Hat Bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.

Comment 1 Fedora Update System 2017-05-30 11:33:32 UTC
hplip-3.17.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-149de72130

Comment 2 Fedora Update System 2017-05-30 11:34:29 UTC
hplip-3.17.4-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a01bbebdee

Comment 3 Fedora Update System 2017-05-30 11:59:57 UTC
hplip-3.17.4-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a783d1436

Comment 4 Fedora Update System 2017-05-30 21:47:15 UTC
hplip-3.17.4-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a783d1436

Comment 5 Fedora Update System 2017-05-31 01:03:50 UTC
hplip-3.17.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-149de72130

Comment 6 Fedora Update System 2017-05-31 01:04:56 UTC
hplip-3.17.4-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a01bbebdee

Comment 7 Fedora Update System 2017-06-08 06:52:55 UTC
hplip-3.17.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-06-08 14:31:47 UTC
hplip-3.17.4-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-06-09 19:15:46 UTC
hplip-3.17.4-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.