Bug 14568 - annoying default tooltips with sawfish
annoying default tooltips with sawfish
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 19:44 EDT by John Cagle
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 08:51:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cagle 2000-07-24 19:44:40 EDT
The sawfish window manager's tooltips are extremely annoying.
If you move a window (like an xterm) and then let up on the mouse,
you'll immediately get a huge tooltip telling you which mouse
buttons to click, etc.

In my opinion, tooltips should be "OFF" by default, or at a minimum
at least remove them after a very short delay (2-3 seconds?).
Comment 1 David Mason 2000-07-24 20:50:45 EDT
Havoc - I don't think they should be off by default but we should try to make
them smaller(less words) and as pretty as possible.
Comment 2 Havoc Pennington 2000-07-25 14:44:54 EDT
We can't really make them smaller/less words except by rewriting all the text,
which is a pretty major project and would break translations.
The only way to control the appearance is to change the color...
Comment 3 John Cagle 2000-07-25 14:49:07 EDT
At a minimum, can't you make them disappear after a short delay (2-3 seconds)?
They're really annoying -- it forces the user to move the mouse off the titlebar.
Comment 4 John Cagle 2000-07-28 12:28:03 EDT
Still exists in pinstripe, in fact, some of the tooltips are bigger than the windows they are a part of...
Comment 5 Christian Rose 2000-08-04 08:50:29 EDT
...and really annoying since most such options (disable tooltips, make tooltips
disappear after a certain time) can't be turned off from inside gnomecc as
gnomecc doesn't save changes (bug 14789).
Comment 6 Havoc Pennington 2000-08-06 00:54:58 EDT
Turned off the tooltips by default

Note You need to log in before you can comment on or make changes to this bug.