Bug 1457382 - portblock monitor flooding /var/log/messages
Summary: portblock monitor flooding /var/log/messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Oyvind Albrigtsen
QA Contact: cluster-qe@redhat.com
Steven J. Levine
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-31 15:33 UTC by Kaleb KEITHLEY
Modified: 2018-05-09 06:59 UTC (History)
7 users (show)

Fixed In Version: resource-agents-3.9.5-112.el7
Doc Type: Bug Fix
Doc Text:
`portblock` agent no longer yields excessive unnecessary messages Previously, the `portblock` agent would flood the `/var/log/messages` file with monitoring messages that provided no useful information. With this fix, the `/var/log/messages` file contains more limited logging output from the `portblock` agent.
Clone Of:
Environment:
Last Closed: 2018-04-10 12:07:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0757 None None None 2018-04-10 12:08:52 UTC

Description Kaleb KEITHLEY 2017-05-31 15:33:51 UTC
Description of problem:

portblock monitor() is "flooding" /var/log/messages like

   notice: vip1_unblock_monitor_10000:16295:stderr [ 0+0 records in ]

and

   notice: vip1_unblock_monitor_10000:16295:stderr [ 0 bytes (0 B) copied, 0.139558 s, 0.0 kB/s ]

End users (customers) are asking if it's safe to ignore these. I told them it is safe, but it'd better if they weren't there at all. They don't seem to be telling them anything useful.

Version-Release number of selected component (if applicable):

resource-agents-3.9.5-82.el7_3.9.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Oyvind Albrigtsen 2017-06-01 12:00:01 UTC
This can be ignored.

We might want to supress these, as they're not relevant for the user.

Comment 3 Oyvind Albrigtsen 2017-07-07 13:33:05 UTC
https://github.com/ClusterLabs/resource-agents/pull/999

Comment 4 michal novacek 2017-08-04 12:10:45 UTC

qa-ack+: portblocker agent should not be excessively logging

Comment 8 Monika Muzikovska 2017-12-07 13:13:01 UTC
Marking Verified in version resource-agents-3.9.5-116.el7.x86_64. 

1) BEFORE fix - /var/log/messages contains excessive logging output from portblocker agent
=============
# rpm -q resource-agents
resource-agents-3.9.5-82.el7_3.11.x86_64

# pcs resource create port_block portblock protocol=tcp portno=5000 action=unblock ip=10.37.165.91 tickle_dir="/tmp/tickle" --group G

# tail /var/log/messages | grep notice
Dec  7 13:48:38 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:19993:stderr [ 0 bytes (0 B) copied, 0.00275961 s, 0.0 kB/s ]
Dec  7 13:48:48 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20076:stderr [ 0+0 records in ]
Dec  7 13:48:48 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20076:stderr [ 0+0 records out ]
Dec  7 13:48:48 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20076:stderr [ 0 bytes (0 B) copied, 0.000689194 s, 0.0 kB/s ]
Dec  7 13:48:58 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20198:stderr [ 0+0 records in ]
Dec  7 13:48:58 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20198:stderr [ 0+0 records out ]
Dec  7 13:48:58 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20198:stderr [ 0 bytes (0 B) copied, 0.00248944 s, 0.0 kB/s ]
Dec  7 13:49:08 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20282:stderr [ 0+0 records in ]
Dec  7 13:49:08 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20282:stderr [ 0+0 records out ]
Dec  7 13:49:08 virt-149 lrmd[17622]:  notice: port_block_monitor_10000:20282:stderr [ 0 bytes (0 B) copied, 0.00277896 s, 0.0 kB/s ]

2) AFTER fix - /var/log/messages does not contain logging output from portblocker agent
=============
# rpm -q resource-agents
resource-agents-3.9.5-116.el7.x86_64

# tail /var/log/messages | grep notice
Dec  7 13:57:57 virt-149 crmd[22113]:  notice: Transition 6 (Complete=6, Pending=0, Fired=0, Skipped=0, Incomplete=0, Source=/var/lib/pacemaker/pengine/pe-input-39.bz2): Complete
Dec  7 13:57:57 virt-149 crmd[22113]:  notice: State transition S_TRANSITION_ENGINE -> S_IDLE

Comment 11 errata-xmlrpc 2018-04-10 12:07:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0757


Note You need to log in before you can comment on or make changes to this bug.