Bug 145765 - reboot hangs
reboot hangs
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-21 06:24 EST by Max
Modified: 2015-01-04 17:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 04:16:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max 2005-01-21 06:24:09 EST
Description of problem:
After digiting reboot command my Dell Poweredge 6400 4 Pentium III
Xeon 900MHz correctly performs shutdown but it does not restart. I
have to switch power off and then on. Thank you very much.


Version-Release number of selected component (if applicable):
2.6.10-1.741_FC3smp

How reproducible:
always

Steps to Reproduce:
1. issue reboot command
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Edgar Hoch 2005-02-22 13:44:24 EST
I have the same problem with Dell PowerEdge 6400 4 Pentium III Xeon
700 MHz and kernel 2.6.10-1.766_FC3smp. I also had this problem with
previous kernels from FC2 and FC3. I don't remember if it rebooted
correctly with RedHat Linux 7.2 - may be.

The installed bios version is A13. There is version A14 available, I
will download and install it. But the update information tells nothing
about this bug so I asume that the bios update does not change the
boot behavior.
Comment 2 Dave Jones 2005-07-15 15:42:52 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Max 2005-07-19 02:50:43 EDT
Hi Dave,
I have updated the kernel to suggested version, the server doesn't start and
says: mkrootdev: label /1 not found
kernel panic - not syncing
I have to boot the old kernel version.
We wait for your suggetions. Thank you.
Best regards
Comment 4 Dave Jones 2005-07-30 01:17:11 EDT
Max, install the mkinitrd update that came out yesterday, then remove (rpm -e),
and reinstall the update kernel.  There was a flaw that caused broken initrd's
with the previous kernel update.
Comment 5 Max 2005-08-22 03:00:59 EDT
Hi Dave,
Linux kernel 2.6.12-1.1372_FC3smp now boots but it does not reboot. Immediatly
after issuing reboot command, monitor becomes black, I don't see usual shutdown
messages but I suppose the server shutdowns because it does not respond to ping.
Nothing more happens, it does not reboot.
Thank you.
Kindest regards
Comment 6 Jeffrey Moyer 2005-10-27 20:58:23 EDT
Could you try using the kernel command line parameter "reboot=force" ?
Comment 7 Max 2005-10-28 04:57:09 EDT
Dear Jeffrey,

I have upgraded kernel to 2.6.12-1.1381_FC3smp with no results: reboot and
reboot -f correctly shutdown the machine but it does not restart.

Kindest regards
Comment 8 Dave Jones 2005-12-07 13:42:42 EST
there are a number of other reboot options you could try..

reboot=w
reboot=c
reboot=b
reboot=h
reboot=s

Please give these a try, and let me know if any of them have any effect.

Thanks.
Comment 9 Max 2005-12-13 10:23:54 EST
Dear Dave,

I tried:

SYNOPSIS
       /sbin/reboot [-n] [-w] [-d] [-f] [-i] 

reboot -w  --> obviously does not restart
reboot -f  --> halt but does not restart
reboot -h  --> halt but does not restart

Thank you
Best regards
Comment 10 Dave Jones 2005-12-14 09:52:41 EST
sorry, I was unclear. These aren't arguments to the reboot command, but boot
command line options. Edit them in grub.
Comment 11 Max 2005-12-14 11:07:08 EST
Dear Dave,

this is my /etc/sysconfig/grub 
boot=/dev/sda
forcelba=0           

and this is grub.conf:
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.12-1.1381_FC3)
        root (hd0,0)
        kernel /vmlinuz-2.6.12-1.1381_FC3 ro root=LABEL=/1 rhgb quiet
        initrd /initrd-2.6.12-1.1381_FC3.img

Exactly which options and in which file have I to put them?
Thank you.
Kindest regards
Comment 12 Dave Jones 2005-12-14 15:48:13 EST
at the end of the 'kernel' line, after 'quiet'
Though you can do this easier without editing this file.
When the grub menu comes up, highlight the kernel to boot, and press 'e'
it'll take you to another screen where you can highlight the kernel line with
the cursor keys. type 'e' again, and you can add the option at the end.
press return when you're done, and then 'b' to boot the kernel.

This way is a lot quicker for testing one-off options than having to edit that
file over and over again.

Comment 13 Max 2005-12-15 09:51:46 EST
Hi Dave,

reboot=w --> machine does not boot
reboot=c --> machine does not boot
reboot=b --> machine does not boot
reboot=h --> machine does not boot
reboot=s --> machine does not boot and prints:

Badness in smp_call_function at arch/i386/kernel/smp.c:571 (not tainted)
[<c011615a>] smp_call_function+0xd8/0xdd
[<c011615a>] scheduler_tick+0xd8/0xdd
[<c011615a>] smp_sent_stop+0xd8/0xdd
[<c011615a>] machine_restart+0xd8/0xdd
[<c011615a>] smp_call_function_interrupt+0xd8/0xdd
[<c011615a>] call_function_interrupt+0xd8/0xdd
[<c011615a>] acpi_processor_idle+0xd8/0xdd
[<c011615a>] cpu_idle+0xd8/0xdd
[<c011615a>] start_kernel+0xd8/0xdd
[<c011615a>] unknown_boot_option+0x0/0x1b0

Thank you.
Kindest regards
Comment 14 Dave Jones 2005-12-15 20:31:54 EST
hmm, does it work if you boot with acpi=off ?
Comment 15 Max 2005-12-16 02:36:00 EST
Hi Dave,

with acpi=off machine does not boot.

Thank you.
Kindest regards
Comment 16 Dave Jones 2006-01-16 17:21:25 EST
This is a mass-update to all currently open Fedora Core 3 kernel bugs.

Fedora Core 3 support has transitioned to the Fedora Legacy project.
Due to the limited resources of this project, typically only
updates for new security issues are released.

As this bug isn't security related, it has been migrated to a
Fedora Core 4 bug.  Please upgrade to this newer release, and
test if this bug is still present there.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

Thank you.
Comment 17 Dave Jones 2006-02-03 01:41:13 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 18 Edgar Hoch 2006-02-08 18:29:35 EST
I have tested with kernel 2.6.15-1.1831_FC4smp at Dell PowerEdge 6400.
It still does not reboot with the reboot command but hangs (wait) after
the shutdown. I have to push the power button (for more than 4 seconds)
then the computer is resetted and boots again.

I also tried with acpi=off, but it still does not reboot. The only difference
is (besides other kernel messages etc) that when I press the power button
the computer is powered off immediately, and I have to press it again to switch
it on... (without acpi=off I have to press it more than 4 seconds and then
it resets the computer, to power off I have to press the button again...).

So it still does not work as is should - I don't know if it is an error of the
bios or the linux kernel.

Thank you, and best regards

Comment 19 Max 2006-02-09 08:01:06 EST
Hi Dave,
I have upgraded to 2.6.15-1.1831_FC4smp, as you suggested,without results. The
bug is still present (also in fc4) as Mr. Hoch is writing in comment #18.
Thank you.
Kindest regards
Comment 20 Dave Jones 2006-09-16 21:55:59 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 21 Edgar Hoch 2006-09-17 07:13:31 EDT
I can't test it with FC5 at the moment because I could not install FC5 on our
Dell Poweredge 6400. FC5 boot CDs don't recognize the RAID Controller because
the megaraid driver in the FC5 install boot kernel is missing or the wrong
version. But the system is (and should be again) installed on one of the RAID
disks controlled by this controller that isn't recognized... so the installation
process don't see the disk to install...

I will wait for FC6 release and try it again. Could the bug still stay open
until this?

Thank you!
Comment 22 petrosyan 2008-02-03 04:16:37 EST
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA", however if you still
experience this problem after updating to our latest Fedora release and are
still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.
Comment 23 lin 2009-09-26 23:01:32 EDT
Hi,

We get smilar problem recently. 
We install CentOS 4.2 on DELL poweredge R710, the kernal is 2.6.9-22ELsmp. The system hang by using reboot/init6, while it could be shutdown/init 0.

The error message shows as:
shuttingdown interface eth0 [ok]
shuttingdown loopback interface [ok]
stopping cupspeed [ok]
stopping systat [ok]
stopping killall [ok]
sending all processe the term signal [ok]
sending all process the kill signal [ok]
saving random seed [ok]
syncing hardware clock to system time [ok]
turning off swap [ok]
turning off quotas [ok]
unmounting pipe file systems [ok]
unmounting file system [ok]
please standby while rebooting the system.
md:stopping all md driveces
md:mdo switched to read-only made
psmouse.c:bad data from KBC-timeout
psmouse.c:bad data from KBC-timeout
restarting system.                 // ths system hangs here

From error message, it possbily related to KVM though there's nothing wrong with using mouse and keyboard. We change mouse/keyboard, or use BMC to login without any mouse/keyboard, the problem is still here.

It's lucky to find this case here. We tried the methods suggested here, unfortunately, they all don't work.

We tried to boot with single CPU kernal, 2.6.9-22EL, the reboot command works find. It seems related to SMP module thing.

Could you please help us on this?

Thank you.

Lin
Comment 24 Edgar Hoch 2009-09-27 10:10:23 EDT
(In reply to comment #23)

CentOS 4.2 and the kernel 2.6.9 is very old. The problem don't exist with current Fedora (tested with Fedora 10 i386 on Dell Poweredge 6400).

I would suggest to install a current linux distribution (for example Fedora 11 or a current version of RHEL or CentOS) including updates to resolve your problem.

For the maintainer of this bug report I suggest to close this bug with solved in current release.

Note You need to log in before you can comment on or make changes to this bug.