Bug 145893 - RFE: lzo package for FC > 2
Summary: RFE: lzo package for FC > 2
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lzo   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-23 11:01 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 20:01:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for devel spec as exported from cvs (1.28 KB, patch)
2005-01-23 11:03 UTC, Arenas Belon, Carlo Marcelo
no flags Details | Diff

Description Arenas Belon, Carlo Marcelo 2005-01-23 11:01:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
current package from devel doesn't build correctly on FC3 because of a
broken test for the assembler on configure.in as detailed on bug 145882.

attached diff with the spec on CVS to fix devel package to include
that fix and create a FC-3 profile

Version-Release number of selected component (if applicable):
lzo-1.08-2

How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild last src.rpm

Actual Results:  no asm optimizations, buildrequire asking for nasm

Expected Results:  asm optimizations, no buildrequire for nasm as it
is not being used (build process uses gcc with preprocessor)

Additional info:

package for configure.in on related bug
current bug affects i386 packages, but there seem not to be any
packages at all for FC3 for any of the supported platforms

Comment 1 Arenas Belon, Carlo Marcelo 2005-01-23 11:03:50 UTC
Created attachment 110102 [details]
patch for devel spec as exported from cvs

Comment 2 Hans de Goede 2006-07-25 20:01:19 UTC
I'm taking over as maintainer from Anvil, since Anvil has other priorities.

Thanks for the patch.

1.08-7 should show up on a mirror near you soon for FC-4, FC-5 and devel.
The changes in 1.08-7 are:
* Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
- Taking over as maintainer since Anvil has other priorities
- Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to
  Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for the initial patch.
- Removed unused build dependency on nasm
- Remove static lib
- Cleanup %doc a bit




Note You need to log in before you can comment on or make changes to this bug.