Bug 1459061 - [QA] Verify hostgroup-based provisioning
[QA] Verify hostgroup-based provisioning
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates (Show other bugs)
6.3.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 04:16 EDT by Lukas Zapletal
Modified: 2017-07-18 15:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-10 14:43:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2017-06-06 04:16:18 EDT
Foreman has a feature called Hostgroup-based rendering

http://projects.theforeman.org/projects/foreman/wiki/templatewriting#Hostgroup-based-rendering

This is not widely used by our community but Satellite customers often seek this feature because of how provisioning worked in Satellite 5. Please ensure this works:

1) Associate host group with an operating system, installation media and architecture in Templates page.
2) Render Default PXE Template using the button
3) PXE boot an unknown host on PXE/DHCP managed network.
4) Menu shows up, hostgroup should appear, install a system with it.

We often see bugs when templates do not render correctly or they do not complete provisioning process. Make sure the host is provisioned and it register itself into Satellite 6.

This is not a blocker feature, but if this fails to pass, we need to fix this in z-stream at least.
Comment 1 Lukas Zapletal 2017-06-06 04:17:10 EDT
Filed doco bug for this as well: https://bugzilla.redhat.com/show_bug.cgi?id=1459062
Comment 3 Brad Buckingham 2017-06-06 13:14:21 EDT
Lukas, is this a request for QE testing of the feature?  Should it be moved to POST?
Comment 4 Lukas Zapletal 2017-06-07 05:04:06 EDT
Yes, sorry bout that. QA only.
Comment 5 Lukas Zapletal 2017-06-08 08:06:10 EDT
I recorded a video that shows the workflow for Satellite 6.3. I hope that gives you enough information how to test and document this.

https://www.youtube.com/watch?v=Dc5DN_Xov40&feature=youtu.be
Comment 14 Bryan Kearney 2017-07-10 14:43:17 EDT
Closing this out. Please use Discovery + rules instead of host group provisioning.

Note You need to log in before you can comment on or make changes to this bug.