Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: While installing monitor node the ceph-installer task fails with error-code 1. The detailed task output is below --> endpoint: /api/mon/install --> succeeded: False --> stdout: Using /usr/share/ceph-ansible/ansible.cfg as config file --> started: 2017-06-06 16:49:14.855054 --> request: {"hosts": ["10.70.41.166", "10.70.41.165", "10.70.43.142"], "calamari": false, "verbose": false, "redhat_use_cdn": true, "redhat_storage": false} --> exit_code: 1 --> ended: 2017-06-06 16:49:17.860619 --> http_method: POST --> command: /bin/ansible-playbook -v -u ceph-installer /usr/share/ceph-ansible/site.yml.sample -i /tmp/04b27064-c224-49b4-9398-cd03d8471424_538ziK --extra-vars {"calamari": false, "ceph_stable": true, "fetch_directory": "/var/lib/ceph-installer/fetch"} --tags package-install --> user_agent: None --> stderr: [WARNING]: log file at /var/log/ansible.log is not writeable and we cannot create it, aborting [DEPRECATION WARNING]: docker is kept for backwards compatibility but usage is discouraged. The module documentation details page may explain more about this rationale.. This feature will be removed in a future release. Deprecation warnings can be disabled by setting deprecation_warnings=False in ansible.cfg. ERROR! the role 'ceph-iscsi-gw' was not found in /usr/share/ceph-ansible/roles:/usr/share/ceph-ansible/roles:/usr/share/ceph-ansible The error appears to have been in '/usr/share/ceph-ansible/site.yml.sample': line 100, column 5, but may be elsewhere in the file depending on the exact syntax problem. The offending line appears to be: roles: - ceph-iscsi-gw ^ here --> identifier: 04b27064-c224-49b4-9398-cd03d8471424 Version-Release number of selected component (if applicable): ceph-ansible-2.2.9-1.el7scon.noarch ceph-installer-1.3.0-1.el7scon.noarch How reproducible: Always Steps to Reproduce: 1. Started creation of a ceph cluster using ceph-installer 2. While installing the monitor node, it failed 3. Actual results: Failed while installing monitor nodes Expected results: Should work seamlessly and create cluster should be done without any error Additional info:
This issue was found and reported here https://bugzilla.redhat.com/show_bug.cgi?id=1454945#c9 We're fixing it as part of that BZ. *** This bug has been marked as a duplicate of bug 1454945 ***