Bug 145926 - Printer configuration hangs when USB printer attached
Printer configuration hangs when USB printer attached
Status: CLOSED DUPLICATE of bug 144536
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-23 19:22 EST by Stuart Rauh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 11:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Rauh 2005-01-23 19:22:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Had HP882c and HP8150 operating on FC2.  Upgraded to FC3 and now the
8150 won't configure.  It is connected via USB.

882 is on the paralel port.  It works fine.

When no USB printer is connected I can click on "New" in Printer
config tool and the configuration dialog appears.  If I plug in the
8150 to USB  then open the print config tool and click "New" I get a
message that says "Loading Printer Information please wait".  When
that message goes away, nothing else happens.

If I run printtool from a terminal, I get the same results along with
this error message...


*** glibc detected *** malloc(): memory corruption: 0x081e8b50 ***
sh: line 1:  5960 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 580, in
new_button_clicked    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 248, in addQueueDruid
    self.populate_device_view ()
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1265, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1392, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install a parallel port printer
2.  Plug in a USB printer
3.  Try to configure the USB printer.
    

Actual Results:  
*** glibc detected *** malloc(): memory corruption: 0x081e8b50 ***
sh: line 1:  5960 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 580, in
new_button_clicked    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 248, in addQueueDruid
    self.populate_device_view ()
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1265, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1392, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment




Expected Results:  Printer should have configured and began operation.

Additional info:
Comment 1 Stuart Rauh 2005-01-23 19:56:24 EST
Sorry, I didn't have the entire error message when I posted.  Here is
the whole thing...

No match for parallel port device:
  mfr "HEWLETT-PACKARD"
  model "DESKJET 880C"
  desc "Hewlett-Packard DeskJet 880C"
  cmdset "MLC,PCL,PML"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
Guessing ID HP-DeskJet_880C for match
*** glibc detected *** malloc(): memory corruption: 0x08226b50 ***
sh: line 1:  5666 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 580, in
new_button_clicked    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 248, in addQueueDruid
    self.populate_device_view ()
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1265, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1392, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment

Comment 2 Tim Waugh 2005-01-24 10:59:42 EST
This message:

*** glibc detected *** malloc(): memory corruption: 0x081e8b50 ***

indicates a bug in the perl program.
Comment 3 Tim Waugh 2005-01-24 11:01:39 EST

*** This bug has been marked as a duplicate of 144536 ***

Note You need to log in before you can comment on or make changes to this bug.