Bug 144536 - (libperl) could not run system-config-printer
(libperl) could not run system-config-printer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
: 144167 145926 146220 162363 163179 (view as bug list)
Depends On:
Blocks: 171111
  Show dependency treegraph
 
Reported: 2005-01-07 17:31 EST by Petr Šplíchal
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version: perl-5.8.5-18.FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 13:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2005-01-07 17:31:08 EST
Description of problem:
my printer stopped working so a i went to system-config-printer, but
found out, that it doesn't work too -- don't know why, everything
worked just fine a month ago, but now i'm not able to do anything
about it

i have fedora core 3 with available updates -- maybe some of the
updates caused it? fresh install worked just fine...

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116-1

How reproducible:
Always

Steps to Reproduce:
run system-config-printer
    

Actual Results:  Traceback (most recent call last):
 File "/usr/sbin/system-config-printer", line 9, in ?
   import queueTree
 File "/usr/share/printconf/util/queueTree.py", line 1236, in ?
   queueTree()
 File "/usr/share/printconf/util/queueTree.py", line 139, in __init__
   self.use_foomatic ()
 File "/usr/share/printconf/util/queueTree.py", line 502, in use_foomatic
   self.conf.foomatic_init_overview ()
 File "/usr/share/printconf/util/printconf_conf.py", line 1584, in
foomatic_init_overview
   root = parser.parse (foo)
 File
"/usr/src/build/461461-i386/install/usr/lib/python2.3/site-packages/_xmlplus/utils/qp_xml.py",
line 134,
xml.parsers.expat.ExpatError: no element found: line 1, column 0

Additional info:

system is fedora core 3 and related software as follows:
cups-libs-1.1.22-0.rc1.8.2
cups-1.1.22-0.rc1.8.2
foomatic-3.0.2-3
hal-cups-utils-0.5.2-8
libgnomecups-0.1.12-5
Omni-foomatic-0.9.2-1.1
Omni-0.9.2-1.1
system-config-printer-gui-0.6.116-1
system-config-printer-0.6.116-1

foomatic-configure -O does a segmentation fault
Comment 1 Tim Waugh 2005-01-10 11:41:52 EST
Please fetch and install this package:

http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/debug/foomatic-debuginfo-3.0.2-3.i386.rpm

Then run this command:

gdb --args foomatic-configure -O

Then at the (gdb) prompt:

(gdb) run

Then once it faults:

(gdb) bt

What does it say?

(If you don't have gdb installed, use 'up2date gdb' to install it.)
Comment 2 Petr Šplíchal 2005-01-10 17:58:07 EST
well, first i didn't work:

gdb --args /usr/bin/foomatic-configure -O
"/usr/bin/foomatic-configure": not in executable format: File format not recognized

(gdb) run
Starting program:  -O
No executable file specified.
Use the "file" or "exec-file" command.
(gdb) quit



then i tried it this way:

gdb --args perl /usr/bin/foomatic-configure -O
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols
found)...Using host libthread_db library "/lib/tls/libthread_db.so.1".

(gdb) run
Starting program: /usr/bin/perl /usr/bin/foomatic-configure -O
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...[Thread
debugging using libthread_db enabled]
[New Thread -151087424 (LWP 4200)]
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -151087424 (LWP 4200)]
0x053b9c15 in Perl_yyparse () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
(gdb) bt
#0  0x053b9c15 in Perl_yyparse () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#1  0x0543461c in Perl_find_runcv () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#2  0x05435fcd in Perl_pp_require () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#3  0x053e2e1d in Perl_runops_debug () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#4  0x0538db06 in Perl_get_cv () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#5  0x05393eab in Perl_call_sv () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#6  0x053944b5 in Perl_call_list () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#7  0x053ca1b0 in Perl_newATTRSUB () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#8  0x053c8946 in Perl_utilize () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#9  0x053ba955 in Perl_yyparse () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#10 0x0543461c in Perl_find_runcv () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#11 0x05435fcd in Perl_pp_require () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#12 0x053e2e1d in Perl_runops_debug () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#13 0x0538db06 in Perl_get_cv () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#14 0x05393eab in Perl_call_sv () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#15 0x053944b5 in Perl_call_list () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#16 0x053ca1b0 in Perl_newATTRSUB () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#17 0x053c8946 in Perl_utilize () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#18 0x053ba955 in Perl_yyparse () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#19 0x0539233e in Perl_moreswitches () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#20 0x0539527c in perl_parse () from
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE/libperl.so
#21 0x0804933a in main ()
Comment 3 Tim Waugh 2005-01-11 04:33:06 EST
Please fetch and install the perl-debuginfo package from the same place and try
again.

This seems to be a perl bug.  Reassigning.
Comment 4 Petr Šplíchal 2005-01-15 06:29:53 EST
(gdb) run
Starting program: /usr/bin/perl /usr/bin/foomatic-configure -O
[Thread debugging using libthread_db enabled]
[New Thread -151087424 (LWP 3688)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -151087424 (LWP 3688)]
0x053b9c15 in Perl_yyparse (my_perl=0x9bae008) at perly.y:169
169                             { $$ = $1; }
(gdb) bt
#0  0x053b9c15 in Perl_yyparse (my_perl=0x9bae008) at perly.y:169
#1  0x0543461c in S_doeval (my_perl=0x9bae008, gimme=0, startop=0x0,
outside=0x0, seq=163786248)
    at pp_ctl.c:2817
#2  0x05435fcd in Perl_pp_require (my_perl=0x9bae008) at pp_ctl.c:3314
#3  0x053e2e1d in Perl_runops_debug (my_perl=0x9bae008) at dump.c:1442
#4  0x0538db06 in S_call_body (my_perl=0x9bae008, myop=0x9c16bdc,
is_eval=0) at perl.c:2289
#5  0x05393eab in Perl_call_sv (my_perl=0x9bae008, sv=0x0, flags=6) at
perl.c:2207
#6  0x053944b5 in Perl_call_list (my_perl=0x9bae008, oldscope=8,
paramList=0x9c12ba0) at perl.c:4722
#7  0x053ca1b0 in Perl_newATTRSUB (my_perl=0x9bae008, floor=314,
o=0x5481ea0, proto=0x8, attrs=0x0,
    block=0x9c15a40) at op.c:4416
#8  0x053c8946 in Perl_utilize (my_perl=0x9bae008, aver=1,
floor=163786248, version=0x0, idop=0x9c15da8,
    arg=0x0) at op.c:2992
#9  0x053ba955 in Perl_yyparse (my_perl=0x9bae008) at perly.y:414
#10 0x0543461c in S_doeval (my_perl=0x9bae008, gimme=0, startop=0x0,
outside=0x0, seq=163786248)
    at pp_ctl.c:2817
#11 0x05435fcd in Perl_pp_require (my_perl=0x9bae008) at pp_ctl.c:3314
#12 0x053e2e1d in Perl_runops_debug (my_perl=0x9bae008) at dump.c:1442
#13 0x0538db06 in S_call_body (my_perl=0x9bae008, myop=0x9c16bdc,
is_eval=0) at perl.c:2289
#14 0x05393eab in Perl_call_sv (my_perl=0x9bae008, sv=0x0, flags=6) at
perl.c:2207
#15 0x053944b5 in Perl_call_list (my_perl=0x9bae008, oldscope=2,
paramList=0x9bc5c18) at perl.c:4722
#16 0x053ca1b0 in Perl_newATTRSUB (my_perl=0x9bae008, floor=103,
o=0x5481ea0, proto=0x2, attrs=0x0,
    block=0x9bc9500) at op.c:4416
#17 0x053c8946 in Perl_utilize (my_perl=0x9bae008, aver=1,
floor=163786248, version=0x0, idop=0x9bc9610,
    arg=0x0) at op.c:2992
#18 0x053ba955 in Perl_yyparse (my_perl=0x9bae008) at perly.y:414
#19 0x0539233e in S_parse_body (my_perl=0x9bae008, env=0x0,
xsinit=0x80493b8 <xs_init>) at perl.c:1769
#20 0x0539527c in perl_parse (my_perl=0x9bae008, xsinit=0x80493b8
<xs_init>, argc=3, argv=0xfefe92d4,
    env=0x0) at perl.c:1273
#21 0x0804933a in main (argc=163786248, argv=0x9c32e08,
env=0xfefe92e4) at perlmain.c:84
Comment 5 Tim Waugh 2005-01-24 11:01:40 EST
*** Bug 145926 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2005-01-26 04:28:19 EST
*** Bug 146220 has been marked as a duplicate of this bug. ***
Comment 7 Warren Togami 2005-05-17 19:51:00 EDT
Same issue as Bug 144167?
Comment 8 Tim Waugh 2005-05-19 04:25:22 EDT
*** Bug 144167 has been marked as a duplicate of this bug. ***
Comment 9 Tim Waugh 2005-07-14 04:34:23 EDT
*** Bug 163179 has been marked as a duplicate of this bug. ***
Comment 11 Tim Waugh 2005-07-28 08:42:15 EDT
*** Bug 162363 has been marked as a duplicate of this bug. ***
Comment 16 Michal Szymanski 2005-11-08 04:57:56 EST
Any chance that this bug will be fixed? Having an operating system *release*
that can't configure an usb printer is somewhat annoying. Is there any simple
workaround other than connecting the printer to the parallel port, configuring,
reconnecting to the USB port and then manually changing the device in
/etc/cupr/printers.conf ?
Michal.
Comment 17 Jason Vas Dias 2005-11-08 11:27:50 EST
I'm very sorry for the problems this has caused.

I'll be issuing a PERL update for FC-3 by the end of this week. 

Until this new perl version fixes the core problem, you could fix it yourself as
follows, by editing the /usr/share/printconf/conf/printconf_conf.py file, 
@ line 1459 - change:  
     magic_perl = "perl -e 'ioctl(STDIN,0x84005001,$result);"
to:
     magic_perl="perl -e '$result=chr(0)x1024;ioctl(STDIN,0x84005001,$result);"

That will fix the problem with the printconf gui .
Comment 18 Jason Vas Dias 2005-12-01 15:41:18 EST
This bug is now fixed with perl-5.8.5-18.FC-3, released to FC-3 updates today.
Comment 19 Fedora Update System 2005-12-01 18:56:00 EST
From User-Agent: XML-RPC

perl-5.8.5-18.FC3 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.