Bug 1459593 - rgw: heavy memory leak when multisite sync fail
rgw: heavy memory leak when multisite sync fail
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.3
Assigned To: Casey Bodley
shilpa
:
: 1448214 1456981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 10:25 EDT by Orit Wasserman
Modified: 2017-07-30 11:49 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHEL: ceph-10.2.7-27.el7cp Ubuntu: ceph_10.2.7-29redhat1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 09:34:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3080861 None None None 2017-06-14 16:20 EDT
Ceph Project Bug Tracker 19446 None None None 2017-06-07 10:25 EDT

  None (edit)
Description Orit Wasserman 2017-06-07 10:25:06 EDT
Description of problem:

heavy memory leak was found when the site sync failed in an active-active multisite clusters (2 sites).

Version-Release number of selected component (if applicable):
upstream 10.2.6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Orit Wasserman 2017-06-07 10:27:50 EDT
upstream fix: https://github.com/ceph/ceph/pull/14714
Comment 12 Matt Benjamin (redhat) 2017-06-09 10:10:12 EDT
*** Bug 1456981 has been marked as a duplicate of this bug. ***
Comment 13 shilpa 2017-06-12 02:08:15 EDT
Based on c#11, moving the BZ to verified.
Comment 15 errata-xmlrpc 2017-06-19 09:34:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497
Comment 16 Casey Bodley 2017-07-10 10:27:42 EDT
*** Bug 1448214 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.