Bug 1459610 - Unable to upload image using chrome 58.0.3029.110 (64-bit) though certificate is configured correctly
Unable to upload image using chrome 58.0.3029.110 (64-bit) though certificate...
Status: CLOSED DUPLICATE of bug 1458545
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.1.3.1
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.1.3
: ---
Assigned To: Daniel Erez
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 10:54 EDT by Natalie Gavrielov
Modified: 2017-06-07 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 11:41:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: exception+


Attachments (Terms of Use)
logs: engine.log, image-proxy.log, vdsm.log, daemon.log (2.52 MB, application/zip)
2017-06-07 10:54 EDT, Natalie Gavrielov
no flags Details

  None (edit)
Description Natalie Gavrielov 2017-06-07 10:54:07 EDT
Created attachment 1285825 [details]
logs: engine.log, image-proxy.log, vdsm.log, daemon.log

Description of problem:
Unable to upload image using chrome 58.0.3029.110 (64-bit) though certificate is configured (firefox 52.1.1 (64-bit) does work).

Version-Release number of selected component:
ovirt-engine-4.1.3.1-0.1.el7.noarch
ovirt-imageio-proxy-1.0.0-0.el7ev.noarch
ovirt-imageio-common-1.0.0-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Download certificate from:
   https://<engine_url>/ovirt-engine/services/pki-resource?resource=ca-certificate&format=X509-PEM-CA
2. Configure certificate in chrome:
   go to settings -> HTTPS/SSL -> manage certficates -> "When using this certificate" "Always trust"
3. Try to upload a disk

Actual results:
After a few seconds upload is marked as "Paused by the system"
engine.log:
2017-06-07 17:30:34,018+03 WARN  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-4) [20c125bb-4f76-4abd-9177-cb80ef6bc392] EVENT_ID: UPLOAD_IMAGE_NETWORK_ERROR(1,038), Correlation ID: 20c125bb-4f76-4abd-9177-cb80ef6bc392, Call Stack: null, Custom Event ID: -1, Message: Unable to upload image to disk 58a50ca6-956c-493c-a41e-f8c577fdd636 due to a network error. Make sure ovirt-imageio-proxy service is installed and configured, and ovirt-engine's certificate is registered as a valid CA in the browser. The certificate can be fetched from https://<engine_url>/ovirt-engine/services/pki-resource?resource=ca-certificate&format=X509-PEM-CA


Expected results:
Upload should succeed 

Additional info:
Also tried to restart chrome after configuring the certificate, but it didn't work.
Comment 3 Natalie Gavrielov 2017-06-07 11:41:31 EDT
Just saw that it's a dup

*** This bug has been marked as a duplicate of bug 1458545 ***

Note You need to log in before you can comment on or make changes to this bug.