Bug 1459637 - remove nashorn extension from eclipse.ini as webtools no longer needs it as of Oxygen.0.M7
Summary: remove nashorn extension from eclipse.ini as webtools no longer needs it as o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: DevTools
Classification: Red Hat
Component: rh-eclipse47
Version: rh-eclipse47
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 1.0
Assignee: Mat Booth
QA Contact: Václav Kadlčík
Robert Krátký
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-07 16:44 UTC by Nick Boldt
Modified: 2017-08-15 15:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-15 15:05:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1389057 unspecified CLOSED Additions/changes to eclipse.ini to support webtools (nashorn extension) and provide more memory to Eclipse for use with... 2020-10-14 00:28:05 UTC
Red Hat Issue Tracker JBDS-4417 Minor Closed Bundle org.eclipse.wst.jsdt.nashorn.extension not found 2017-08-16 16:43:52 UTC
Red Hat Product Errata RHEA-2017:2476 normal SHIPPED_LIVE rh-eclipse47 bug fix and enhancement update 2017-08-15 19:01:40 UTC

Description Nick Boldt 2017-06-07 16:44:06 UTC
Description of problem:

In https://bugzilla.redhat.com/show_bug.cgi?id=1389057 we added this extension to eclipe.ini:

-Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension

But as of Oxygen.0.M7, this is no longer needed as WTP uses Closure instead. Details, see https://issues.jboss.org/browse/JBDS-4417 and https://github.com/jbdevstudio/jbdevstudio-product/pull/456

Version-Release number of selected component (if applicable):

rh-eclipse47 (not 46)
webtools 3.9.x


How reproducible:

always

Steps to Reproduce:
1. install rh-eclipse47. look in /opt/rh/rh-eclipse46/root/usr/lib64/eclipse/eclipse.ini for the nashorn line
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Nick Boldt 2017-06-23 22:29:16 UTC
Appears to be NOT fixed as of rh-eclipse47-eclipse-platform.x86_64 1:4.7.0-0.14.4.el7:

$➔ cd /opt/rh/rh-eclipse46/root/usr/lib64/eclipse/
$➔ cat eclipse.ini | grep nash
 
-Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension

Comment 3 Nick Boldt 2017-06-23 22:45:21 UTC
Correction, was looking in the wrong place.

/opt/rh/rh-eclipse47/root/usr/lib/eclipse/eclipse.ini has no reference to nashorn.extension.

So this is fixed. I guess I mark it ON_QA?

Comment 7 errata-xmlrpc 2017-08-15 15:05:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2476


Note You need to log in before you can comment on or make changes to this bug.