Bug 145978 - remove %_libdir/lib*.la files
remove %_libdir/lib*.la files
Status: CLOSED DUPLICATE of bug 174261
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 09:19 EST by Rex Dieter
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 07:56:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-01-24 09:19:00 EST
You can safely drop/remove %_libdir/libSDL.la from the package. 
These will reduce libtool/library bloat.

Further, it will (mostly) solve the problem of needing to install
extreneous packages(*) in order to build anything that uses libtool
and rpm-devel.

(*) like libselinux-devel, beecrypt-devel, elfutils-devel

(mostly Library) packages with .la files of their own that
BuildRequires: rpm-devel
(probably) will need to be rebuilt after this modification.
Comment 1 Jeff Johnson 2005-01-24 10:17:43 EST
I desire *.la files in rpm packaging.
Comment 2 Rex Dieter 2005-01-24 10:38:14 EST
May ask why?  When it adds no value, and only leads to extraneous
library Requires/linking(*) when anyone uses rpm-devel?

(*) Like the aforementioned libselinux-devel, beecrypt-devel,
elfutils-devel

If you're not going to do it (IMO) the cleanest way (removing the .la
files), at least add to -devel:
Requires: libselinux-devel, beecrypt-devel, elfutils-devel
Comment 3 Jeff Johnson 2005-01-25 14:25:18 EST
Sure.

For starters, *.la files solve non-linux portability problems,
where, for example, mac os x uses *.dyld rather than *.so.

Also *.la files are a portable alternative for specifying
library <-> library flags. pkg-config is not widely deployed
on non-linux.

And finally, because I find rpm maintenance with *.la easier
than the other, known alternatives.
Comment 4 Rex Dieter 2005-01-25 14:36:21 EST
Jeff, 

I wasn't suggesting removing the .la files from the rpm tarball/build,
only removing them from the redhat/fedora-core packaging of it (ie,
append to the %install section of the specfile:
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
Comment 5 Rex Dieter 2006-04-26 07:54:35 EDT
Nice to see the .la files were finally removed (see bug #174261 comment 2,3).
Comment 6 Rex Dieter 2006-04-26 07:56:15 EDT

*** This bug has been marked as a duplicate of 174261 ***

Note You need to log in before you can comment on or make changes to this bug.