Bug 174261 - popt must not include .la file or be split in popt and popt-devel
popt must not include .la file or be split in popt and popt-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: FutureFeature
: 145978 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 15:52 EST by Hans de Goede
Modified: 2011-09-21 13:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 10:30:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2005-11-26 15:52:59 EST
Hi,

I hit a build problem on x86_64 with some sw I'm trying to package. The real
problem is in the sw but I noticed that the popt.i386 package also installs
libpopt.a libpopt.la and libpopt.so which are ofcourse completly unneeded on a
multilib system where this package is not of the primary lib arch.

Also isn't shipping .la files concidered not done/wanted in Fedora lately?
Comment 1 Hans de Goede 2005-11-26 16:17:52 EST
Further research has learned that the real problem is actually in the popt
package. If libtool sees a .la file in both /usr/lib and /usr/lib64 it does
funny things.

When libtool gets passed -lpopt on a link command it passes /usr/lib/libpopt.so
to gcc which of course is wrong on x86_64, it should be /usr/lib64/libpopt.so,
or preferably just -lpopt

Removing the .la file from /usr/lib fixes things for me. Luckily the buildsystem
doesn't have this kinda troubles, still this needs fixing.

Since a split would only save a few bytes I think that dropping the .la file
will suffice.
Comment 2 Paul Nasrat 2005-11-28 09:20:05 EST
Changed spec file to %exclude, will be pulled in when the next build of RPM for
rawhide is done.
Comment 3 Radek Vokal 2005-12-07 08:56:23 EST
After rpm update I still see that files like librpm.la are having depedency on
lipopt.la. Those should be also removed or excluded. 
Comment 4 Paul Nasrat 2005-12-07 10:30:29 EST
rpm-4.4.2-11
Comment 5 Rex Dieter 2006-04-26 07:54:27 EDT
Glad to see the .la files finally removed, despite my report asking for the same
thing (bug #145978) was marked WONTFIX.
Comment 6 Rex Dieter 2006-04-26 07:57:00 EDT
*** Bug 145978 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2011-09-21 13:22:37 EDT
kdebase-4.6.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kdebase-4.6.5-2.fc14
Comment 8 Rex Dieter 2011-09-21 13:25:48 EDT
(sorry about the typo'd bodhi spam)

Note You need to log in before you can comment on or make changes to this bug.