Bug 1459908 - Rest API does not report network statistics host "data.current.tx, data.current.rx"
Summary: Rest API does not report network statistics host "data.current.tx, data.curre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1434006 1408963 1502510 1573145
TreeView+ depends on / blocked
 
Reported: 2017-06-08 14:09 UTC by Marian Jankular
Modified: 2019-05-16 13:03 UTC (History)
14 users (show)

Fixed In Version: ovirt-engine-4.2.0-0.0.master.20170901193740.git7900511.el7.centos.noarch.rpm
Doc Type: Enhancement
Doc Text:
The precision of the rx_rate, tx_rate, rx_drop, and tx_drop of virtual and host network interfaces has been increased, enabling the REST API to generate more accurate network interface statistics.
Clone Of:
: 1502510 1573145 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:43:21 UTC
oVirt Team: Network


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:45:04 UTC
oVirt gerrit 80524 master POST engine: Increase precision of rx_rate and tx_rate 2017-08-30 14:49:27 UTC

Description Marian Jankular 2017-06-08 14:09:47 UTC
Description of problem:
Rest API does not report network statistics host "data.current.tx, data.current.rx"

Version-Release number of selected component (if applicable):
rhevm 4.0.3-0.1.el7ev
rhvh 4.0.5.2
rhvh 4.0.7.1


How reproducible:
everytime

Steps to Reproduce:
1. install rhevm and hypervisor
2. connect hypervisor to rhevm
3. query app

"curl -s -k -X GET -H "Accept: application/json" -u admin@internal:redhat https://rhevm.example.com/ovirt-engine/api/hosts/host_uuid/nics/nic_uuid/statistics"

Actual results:
   "host_nic" : {
      "href" : "/ovirt-engine/api/hosts/0d6fdb5d-7fc5-40a7-a8fe-dd2ab75143a1/nics/ca159e66-1f76-4d9e-b072-d6146c665722",
      "id" : "ca159e66-1f76-4d9e-b072-d6146c665722"
    },
    "name" : "data.current.rx",
    "description" : "Receive data rate",
    "href" : "/ovirt-engine/api/hosts/0d6fdb5d-7fc5-40a7-a8fe-dd2ab75143a1/nics/ca159e66-1f76-4d9e-b072-d6146c665722/statistics/ecd0559f-e88f-3330-94b4-1f091b0ffdf7",
    "id" : "ecd0559f-e88f-3330-94b4-1f091b0ffdf7"
  }, {
    "kind" : "gauge",
    "type" : "decimal",
    "unit" : "bytes_per_second",
    "values" : {
      "value" : [ {
        "datum" : 0
      } ]
    },
    "host_nic" : {
      "href" : "/ovirt-engine/api/hosts/0d6fdb5d-7fc5-40a7-a8fe-dd2ab75143a1/nics/ca159e66-1f76-4d9e-b072-d6146c665722",
      "id" : "ca159e66-1f76-4d9e-b072-d6146c665722"
    },
    "name" : "data.current.tx",
    "description" : "Transmit data rate",
    "href" : "/ovirt-engine/api/hosts/0d6fdb5d-7fc5-40a7-a8fe-dd2ab75143a1/nics/ca159e66-1f76-4d9e-b072-d6146c665722/statistics/2c6fe105-4913-3f90-9425-07ddfeca5417",
    "id" : "2c6fe105-4913-3f90-9425-07ddfeca5417"
  }, {
    "kind" : "counter",
    "type" : "integer",
    "unit" : "bytes",
    "values" : {
      "value" : [ {
        "datum" : 286967489913
      } ]
    },


Expected results:
values for current statistics

Additional info:

Comment 1 Martin Perina 2017-06-09 12:58:09 UTC
RX/TX values in API are computed from RX/TX percentages and max bandwidth of the interface (provided by speed attribute), so if speed is zero, the also RX/TX are zeros.

Could you please take a look at the value of speed attribute? If it's non-zero could you please check RX/TX values in webadmin if they are the same as in API?

Comment 2 Marian Jankular 2017-06-15 07:37:35 UTC
in my setup i have speed 0, and rx/tx values are "<1"

Comment 3 Yaniv Kaul 2017-06-15 12:44:39 UTC
(In reply to Marian Jankular from comment #2)
> in my setup i have speed 0, and rx/tx values are "<1"

Can you try and run some traffic over?

Comment 4 Marian Jankular 2017-06-16 10:19:36 UTC
I did tried on our 4.1 environment which has load - 20 vms per node

in web ui i see speed 1000, rx rate is 10, txrate is <1 however when using api i am still getting no value for current 

    "name" : "data.current.rx",
    "description" : "Receive data rate",
    "href" : "/ovirt-engine/api/hosts/f1e96245-7ca3-4729-8abf-980501380a2b/nics/a442b3d7-7d3e-456b-a9cb-900d22171464/statistics/ecd0559f-e88f-3330-94b4-1f091b0ffdf7",
    "id" : "ecd0559f-e88f-3330-94b4-1f091b0ffdf7"
  }, {
    "kind" : "gauge",
    "type" : "decimal",
    "unit" : "bytes_per_second",
    "values" : {
      "value" : [ {
        "datum" : 0
      } ]
    },
    "host_nic" : {
      "href" : "/ovirt-engine/api/hosts/f1e96245-7ca3-4729-8abf-980501380a2b/nics/a442b3d7-7d3e-456b-a9cb-900d22171464",
      "id" : "a442b3d7-7d3e-456b-a9cb-900d22171464"
    },
    "name" : "data.current.tx",
    "description" : "Transmit data rate",
    "href" : "/ovirt-engine/api/hosts/f1e96245-7ca3-4729-8abf-980501380a2b/nics/a442b3d7-7d3e-456b-a9cb-900d22171464/statistics/2c6fe105-4913-3f90-9425-07ddfeca5417",
    "id" : "2c6fe105-4913-3f90-9425-07ddfeca5417"
  }, {
    "kind" : "counter",
    "type" : "integer",
    "unit" : "bytes",
    "values" : {
      "value" : [ {
        "datum" : 199652833504
      } ]

Comment 5 Martin Perina 2017-06-21 09:28:47 UTC
I'm not able to reproduce on RHVM 4.1.2, it works as expected (checked on several hosts):

1. When rx/tx rate in webadmin is <1, then it's shown as 0 in restapi
2. When speed is non-zero and rx/tx rate in webadmin are different than <1, non-zero values are shown in restapi

@Dan, is there any known issue around this area?

Comment 6 Oved Ourfali 2017-06-25 05:38:44 UTC
Moving to network team.

Comment 7 Yaniv Lavi 2017-07-05 07:25:30 UTC
We are planning to release a metrics store next month that will allow you to collect raw value more accurately. The customer will probably want to move to this for monitoring.

Comment 8 Yaniv Lavi 2017-07-05 07:26:24 UTC
If we change the value type then the DWH will need to be changed as well.

Comment 9 Dan Kenigsberg 2017-07-16 15:35:40 UTC
(In reply to Martin Perina from comment #5)
> I'm not able to reproduce on RHVM 4.1.2, it works as expected (checked on
> several hosts):
> 
> 1. When rx/tx rate in webadmin is <1, then it's shown as 0 in restapi
> 2. When speed is non-zero and rx/tx rate in webadmin are different than <1,
> non-zero values are shown in restapi
> 
> @Dan, is there any known issue around this area?

I remember sradco complaining about something similar in the past. Do you recall a bz#?

Comment 13 Michael Burman 2017-09-03 13:06:47 UTC
Verified on - 4.2.0-0.0.master.20170901193740.git7900511.el7.centos

Comment 14 Oved Ourfali 2017-10-16 07:09:07 UTC
Dan - can we push to 4.1.z?
A CFME bug depends on that one.

Comment 15 Dan Kenigsberg 2017-10-16 07:16:02 UTC
(In reply to Oved Ourfali from comment #14)
> Dan - can we push to 4.1.z?
> A CFME bug depends on that one.

yes, it should not be hard.

Comment 19 errata-xmlrpc 2018-05-15 17:43:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 20 Franta Kust 2019-05-16 13:03:29 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.