Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573145 - Update hosts and vms receive_rate_percent and transmit_rate_percent network statistics precision
Summary: Update hosts and vms receive_rate_percent and transmit_rate_percent network s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dwh
Classification: oVirt
Component: ETL
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Shirly Radco
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On: 1459908
Blocks: 1581854 1631202
TreeView+ depends on / blocked
 
Reported: 2018-04-30 10:43 UTC by Shirly Radco
Modified: 2019-04-28 08:41 UTC (History)
17 users (show)

Fixed In Version: ovirt-engine-dwh-4.2.4.3
Doc Type: If docs needed, set a value
Doc Text:
Cause: The precision of the rx_rate, tx_rate of virtual and host network interfaces has been increased on the engine db. Consequence: This requires updating the dwh precision for better reporting. Fix: Update hosts and vms receive_rate_percent and transmit_rate_percent network statistics precision Result: Hosts and vms receive_rate_percent and transmit_rate_percent network statistics precision was increased on DWH.
Clone Of: 1459908
Environment:
Last Closed: 2018-06-26 08:37:42 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91413 0 ovirt-engine-dwh-4.2 MERGED history: update rx and tx rate percent percition 2020-09-10 07:51:22 UTC
oVirt gerrit 91414 0 master MERGED history: update rx and tx rate percent percition 2020-09-10 07:51:23 UTC
oVirt gerrit 92065 0 master MERGED history: fix bug in rx and tx rate percent percition 2020-09-10 07:51:23 UTC
oVirt gerrit 92067 0 ovirt-engine-dwh-4.2 MERGED history: fix bug in rx and tx rate percent percition 2020-09-10 07:51:23 UTC
oVirt gerrit 92070 0 master MERGED dwh: remove casting of rx and tx rates in dwh views 2020-09-10 07:51:23 UTC
oVirt gerrit 92164 0 ovirt-engine-4.2 MERGED dwh: remove casting of rx and tx rates in dwh views 2020-09-10 07:51:23 UTC

Description Shirly Radco 2018-04-30 10:43:25 UTC
Description of problem:
Update hosts and vms receive_rate_percent and transmit_rate_percent network statistics precision, based on the changes made in Bug #1459908.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install rhevm and hypervisor and dwh
2. check data collected to the ovirt_engine_history db for hosts and vms
3. query app

Comment 1 Lucie Leistnerova 2018-06-07 12:45:23 UTC
All rx/tx percent rate columns in dwh database changed to decimal(18, 4). 
But stored numbers in host_interface_samples_history - receive_rate_percent/transmit_rate_percent are without decimals.

engine statistics:

engine=# select * from vds_interface_statistics;
                  id                  |                vds_id                | rx_rate
 351735ba-d45f-4521-b75f-54afbc3e8ec6 | 0b15bc11-cff7-4e17-8e00-3acac5054c57 | 22.1555 |  0.1327 |

dwh:

ovirt_engine_history=# select * from host_interface_samples_history where host_interface_id='351735ba-d45f-4521-b75f-54afbc3e8ec6' order by history_datetime desc limit 10;
 history_id |      history_datetime      |          host_interface_id           | receive_rate_percent | transmit_rate_percent
     526033 | 2018-06-07 13:39:51.604+02 | 351735ba-d45f-4521-b75f-54afbc3e8ec6 |              22.0000 |                0.0000


The same is with vm_interface_samples_history table.


tested in ovirt-engine-dwh-4.2.4-1.el7ev.noarch

Comment 2 Shirly Radco 2018-06-07 15:44:25 UTC
A fix was required also on the engine dwh views.
Also missed adding tos_project files to the patch.

Please test on both master and 4.2 branches because the code is different.

Comment 3 Sandro Bonazzola 2018-06-15 09:44:07 UTC
Requires ovirt-engine-4.2.4.4

Comment 4 Lucie Leistnerova 2018-06-20 05:59:27 UTC
All rx/tx percent rate columns are stored with the precision now.

verified in ovirt-engine-dwh-4.3.0-0.0.master.20180607152407.el7.noarch and ovirt-engine-dwh-4.2.4.3-1.el7ev.noarch

Comment 5 Sandro Bonazzola 2018-06-26 08:37:42 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.