Bug 1460028 - In keywrap mode, key recovery on KRA with HSM causes KRA to crash
In keywrap mode, key recovery on KRA with HSM causes KRA to crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fraser Tweedale
Asha Akkiangady
:
: 1460029 (view as bug list)
Depends On:
Blocks: 1460029
  Show dependency treegraph
 
Reported: 2017-06-08 17:22 EDT by Matthew Harmsen
Modified: 2017-09-01 11:14 EDT (History)
4 users (show)

See Also:
Fixed In Version: pki-core-10.4.1-9.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1460029 (view as bug list)
Environment:
Last Closed: 2017-08-01 18:52:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Harmsen 2017-06-08 17:22:11 EDT
This bug is created as a clone of upstream ticket:
https://pagure.io/dogtagpki/issue/2728

Originally, because the AES  KEY_WRAP algorithm was not suported by the HSM, we needed to put the KRA in encrypt mode.

Recent code has allowed us to specify the AES-CBC-128 mode for key wrapping algorithm, and to allow  the KRA to be in key wrap mode.  However, in this mode, when a key recovery is attempted, 
the KRA crashes due to a null pointer derefernece  in the HSM (on a FIPS machine(.
Comment 2 Ade Lee 2017-06-09 14:30:35 EDT
Author: Fraser Tweedale <ftweedal@redhat.com>
Date:   Thu Jun 8 14:25:23 2017 +1000

    KRA PKCS #12 export: add config to use 3DES PBE encryption
    
    Restore the 3DES PKCS #12 key recovery code path, alongside the new
    AES variant, which is broken on Thales nethsm.  Add the
    'kra.legacyPKCS12' config for selecting which version to use, with
    the default value of 'true' (i.e., use 3DES).
    
    Part of: https://pagure.io/dogtagpki/issue/2728
    
    Change-Id: Ic02fe8ba3a4c2c049913ff48d3f6dfdc830b4360
Comment 4 Roshni 2017-06-23 15:59:29 EDT
[root@nocp1 ~]# rpm -qi pki-kra
Name        : pki-kra
Version     : 10.4.1
Release     : 10.el7
Architecture: noarch
Install Date: Wed 21 Jun 2017 11:00:26 AM EDT
Group       : System Environment/Daemons
Size        : 562173
License     : GPLv2
Signature   : (none)
Source RPM  : pki-core-10.4.1-10.el7.src.rpm
Build Date  : Tue 20 Jun 2017 01:23:22 AM EDT
Build Host  : ppc-046.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://pki.fedoraproject.org/
Summary     : Certificate System - Key Recovery Authority

Key recovery on token using external registration works with HSM and FIPS enabled enviroment with AES encryption. This was tested successfully usng SCP01 and SCP03 cards.
Comment 5 errata-xmlrpc 2017-08-01 18:52:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2110
Comment 6 Matthew Harmsen 2017-09-01 11:14:41 EDT
*** Bug 1460029 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.