Bug 1460198 - RFE: enable LZ4 compression in spice-gtk
RFE: enable LZ4 compression in spice-gtk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: 7.5
Assigned To: Victor Toso
SPICE QE bug list
: FutureFeature
Depends On: 1432958
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 07:02 EDT by David Jaša
Modified: 2018-04-10 04:51 EDT (History)
9 users (show)

See Also:
Fixed In Version: spice-gtk-0.34-2.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1460191
Environment:
Last Closed: 2018-04-10 04:50:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0672 None None None 2018-04-10 04:51 EDT

  None (edit)
Description David Jaša 2017-06-09 07:02:12 EDT
Description of problem:
LZ4 is good algorithm in both low CPU utilization and high compression ratio so it would be nice to have it as a RHEL default.
This bug depends on lz4 library inclusion in el7.

Version-Release number of selected component (if applicable):
RHEL 7.4 / spice-server-0.12.8-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Victor Toso 2017-06-09 07:07:55 EDT
Yes, Not much to be done in the codebase, we just need lz4 lib in.
Comment 5 Radek Duda 2017-12-19 10:07:22 EST
could you give me a hint how to verify this one?
I see liblz4.so.1()(64bit) among required (rpm -qR spice-gtk3), but no mention of lz4 in spice-debug log nor debug log..
So how to detect that data are actually compressed?
Comment 6 Victor Toso 2017-12-19 11:16:19 EST
(In reply to Radek Duda from comment #5)
> could you give me a hint how to verify this one?
> I see liblz4.so.1()(64bit) among required (rpm -qR spice-gtk3), but no
> mention of lz4 in spice-debug log nor debug log..
> So how to detect that data are actually compressed?

$ ldd /usr/lib64/libspice-client-gtk-3.0.so | grep -i lz4
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007fec70915000)

$ ldd /usr/lib64/libspice-client-glib-2.0.so | grep -i lz4
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007fba8bedc000)

$ remote-viewer --help-spice | grep -i lz4
  --spice-preferred-compression=<auto-glz,auto-lz,quic,glz,lz,lz4,off>  Preferred image compression algorithm

and you should have no problems while using lz4 compression.
Comment 10 errata-xmlrpc 2018-04-10 04:50:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0672

Note You need to log in before you can comment on or make changes to this bug.