Bug 146023 - ltp tests can`t run under Midnight Commander
Summary: ltp tests can`t run under Midnight Commander
Status: CLOSED DUPLICATE of bug 123408
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mc (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-24 19:38 UTC by Alex Lyashkov
Modified: 2013-07-02 23:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:08:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Lyashkov 2005-01-24 19:38:53 UTC
Description of problem:
LTP tests can`t be run if it been started at MC subshell, but if i
start at it without MC all tests run correctly.

Version-Release number of selected component (if applicable):
2.4.21-27.0.1

How reproducible:
always

Steps to Reproduce:
1. rebuild and install mc from FC1 package.
2. make and install LTP test suite
3. run default tests from LTP.
  
Actual results:
test can`t been exited.

Expected results:
work ok.

Additional info:
Kernel trace is available at bug 123408.

Comment 1 Jindrich Novy 2005-01-25 07:40:48 UTC
Hello Alex,

mc upstream released another release candidate for mc (4.6.1-pre3) which I want
to include to RHEL3. The FC1 version of mc is very obsolete and many of bugs
were fixed in the mentioned prerelease. Some users replied to me that they're
happy with the version of mc I released for FC3 update in december and it works
fine for them.

mc subshell fixes were one of the main interests in recent development.

Please try:
http://sunsite.mff.cuni.cz/pub/fedora/3/SRPMS/mc-4.6.1-0.8.src.rpm

or the latest devel:
http://sunsite.mff.cuni.cz/pub/fedora/development/SRPMS/mc-4.6.1a-0.3.src.rpm

Note that FC1 is a legacy project now, which is not officially supported now.

Comment 2 Alex Lyashkov 2005-01-25 08:49:10 UTC
Please try:
http://sunsite.mff.cuni.cz/pub/fedora/3/SRPMS/mc-4.6.1-0.8.src.rpm

can`t build under fully updated RH EL3(AS)
1) first it need gettext-devel. but this package can`t be found at RHN.
2) after this requestion comented - it stop configure with messages.
Upgrade gettext to at least 0.11.5 or downgrade to 0.10.40
...
# rpm -qa | grep gettext
gettext-0.11.4-7
but i can`t find these at beta channels also.

And I think this not a MC problem. If i right program frezed at signal delivery.
It posible trigered with MC but it not are MC bug.

Comment 3 Jindrich Novy 2005-01-25 09:12:31 UTC
To fix the compilation problem under RHEL3, please delete lines 56-59 in
autogen.sh. gettext-devel package isn't present in RHEL3 and you can safely drop
this requirement because it was done because of autopoint which is moved to
gettext-devel in development branch.

Right, it also doesn't look like a mc bug to me.

Comment 4 Alex Lyashkov 2005-01-25 10:13:29 UTC
Who you set to this bug resolution - 'Not a bug', if this bug are stil and not
fixed? At start i set 'kernel' category and if its kernel bug please reasign to
person who can find and fix this bug.

Comment 5 Jindrich Novy 2005-01-26 07:52:01 UTC
I set the resolution to NOTABUG because an unsupported package (FC1 mc
on RHEL3) is used, therefore it's not a bug in RHEL3 distribution and
mc. On the second thought it's better to mark this bug as duplicate of
bug 123408.

Thanks,
Jindrich

*** This bug has been marked as a duplicate of 123408 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:08:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.