Bug 1460260 - High CPU Utilization Openshift process (Origin v1.4)
High CPU Utilization Openshift process (Origin v1.4)
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.z
Assigned To: hchen
Wenqi He
:
Depends On:
Blocks: 1460271 1460280
  Show dependency treegraph
 
Reported: 2017-06-09 10:01 EDT by hchen
Modified: 2017-08-04 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Older kube libraries required directory rename instead of delete. Consequence: High CPU in some situations. Fix: Delete emptyDir instead of rename. Result: No more high CPU.
Story Points: ---
Clone Of:
: 1460271 (view as bug list)
Environment:
Last Closed: 2017-07-11 06:47:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hchen 2017-06-09 10:01:52 EDT
Description of problem:
Description at https://github.com/openshift/origin/issues/14428 

Version-Release number of selected component (if applicable):
oc v1.4.0+208f053
kubernetes v1.4.0+776c994
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:


Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:
Comment 3 Wenqi He 2017-06-22 07:40:42 EDT
I have tested OCP on below version:
openshift v3.4.1.42
kubernetes v1.4.0+776c994

I have run related emptyDir test cases for a large number times, did not find the error message in "UnmountVolume.TearDown failed for volume" and no high CPU utilization found. Change status to verified. Thanks.
Comment 5 errata-xmlrpc 2017-07-11 06:47:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1640

Note You need to log in before you can comment on or make changes to this bug.