Bug 1460266 - live-restore fails due to KillMode=process missing from unit file
live-restore fails due to KillMode=process missing from unit file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks: 1460268
  Show dependency treegraph
 
Reported: 2017-06-09 10:09 EDT by Ed Santiago
Modified: 2017-08-01 20:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: docker-1.12.6-35.1.git6ffd653.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1460268 (view as bug list)
Environment:
Last Closed: 2017-08-01 20:11:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2344 normal SHIPPED_LIVE docker bug fix and enhancement update 2017-08-08 18:51:38 EDT

  None (edit)
Description Ed Santiago 2017-06-09 10:09:49 EDT
RHEL 7.4, docker-1.12.6-33.1.git3a6eaeb.el7.x86_64. Running docker daemon with --live-restore:

   1) systemctl stop docker takes 90 seconds to complete
   2) systemctl start docker kills any running containers

Solution, per bug 1424709, is adding KillMode=process to the systemd unit file.
Comment 2 Daniel Walsh 2017-06-09 10:53:10 EDT
Lokesh it seems this change has made it into rhel7.3.5 but not RHEL7.4?
Comment 4 Ed Santiago 2017-06-15 07:46:12 EDT
Confirmed fixed in docker-1.12.6-39.1.git6ffd653.el7
Comment 6 errata-xmlrpc 2017-08-01 20:11:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2344

Note You need to log in before you can comment on or make changes to this bug.