Bug 1460268 - live-restore fails due to KillMode=process missing from unit file
live-restore fails due to KillMode=process missing from unit file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker-latest (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On: 1460266
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 10:11 EDT by Ed Santiago
Modified: 2017-08-01 20:14 EDT (History)
5 users (show)

See Also:
Fixed In Version: docker-latest-1.13.1-19.1.git19ea2d3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1460266
Environment:
Last Closed: 2017-08-01 20:14:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Daniel Walsh 2017-06-09 10:54:31 EDT
Lokesh it seems this change has made it into rhel7.3.5 but not RHEL7.4?
Comment 4 Ed Santiago 2017-06-13 18:10:09 EDT
Lokesh could you please triple-check this? I've installed docker-latest-1.13.1-16.1.git19ea2d3.el7 and still see:

    systemctl show --property=KillMode docker-latest
    KillMode=control-group

I've unpacked the srpm, examined the spec, and don't see any code addressing this BZ.
Comment 5 Ed Santiago 2017-06-15 07:53:50 EDT
CConfirmed fixed in docker-latest-1.13.1-19.1.git19ea2d3.el7
Comment 7 errata-xmlrpc 2017-08-01 20:14:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2345

Note You need to log in before you can comment on or make changes to this bug.