Bug 1460326 - need to backport liveness fix to avoid random crashes and corruption
need to backport liveness fix to avoid random crashes and corruption
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Antonio Murdaca
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 13:25 EDT by Neil Horman
Modified: 2017-08-01 20:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: docker-1.12.6-35.1.git6ffd653.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1460784 (view as bug list)
Environment:
Last Closed: 2017-08-01 20:11:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Horman 2017-06-09 13:25:07 EDT
Description of problem:
We need to pull back this change:
https://github.com/moby/moby/pull/33376
To docker.  Without it, lvm operations can randomly cause crashes and other transient errors
Comment 2 Antonio Murdaca 2017-06-09 14:52:17 EDT
Backported in 1.12.x and 1.13.x-rhel:

https://github.com/projectatomic/docker/commits/docker-1.12.6
https://github.com/projectatomic/docker/commits/docker-1.13.1
https://github.com/projectatomic/docker/commits/docker-1.13.1-rhel

This just needs a rebuild in RHEL I guess /cc'ing Lokesh
Comment 8 errata-xmlrpc 2017-08-01 20:11:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2344

Note You need to log in before you can comment on or make changes to this bug.