Bug 1460456 - BUG: unable to handle kernel paging request at xxxx in 4.11.3
Summary: BUG: unable to handle kernel paging request at xxxx in 4.11.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1461211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-10 21:21 UTC by Albert Vernon
Modified: 2017-06-16 18:52 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-16 18:52:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Albert Vernon 2017-06-10 21:21:28 UTC
Description of problem:

I see the message "BUG: unable to handle kernel paging request at xxxx" and get a kernel panic.

Version-Release number of selected component (if applicable):

Linux kernels 4.11.3-200.fc25.x86_64 and 4.11.3.202.fc25.x86_64.

How reproducible:

100% of the time.

Steps to Reproduce:

Boot into either of the above kernels.

Actual results:

The kernel panics with the following stack trace:

https://imgur.com/a/fHTCk

Expected results:

Kernel should boot.

Additional info:

1. If I press "e" at the GRUB menu, remove "quiet" from the boot parameters, and press Ctrl+X to continue, the kernel boots successfully.

2. I tried to get a kernel core dump using kdump, but nothing appears in /var/crash. If I manually trigger a panic with "echo c > /proc/sysrq-trigger", then I do see a core file.

3. There is an additional discussion here: https://ask.fedoraproject.org/en/question/106433/fail-to-boot-after-the-last-two-kernel-updates/

4. Output of lspci on my computer:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.6 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 7 (rev c4)
00:1c.7 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Z77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
03:00.0 Network controller: Broadcom Limited BCM43228 802.11a/b/g/n
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller

Comment 1 Albert Vernon 2017-06-10 22:45:41 UTC
I've discovered that blacklisting nouveau allows my computer to finish booting.

Comment 2 Laura Abbott 2017-06-12 15:09:39 UTC
Can you capture more of the stacktrace right after the "nvkm_timer_alarm_trigger" line? That will help give more information

Comment 3 Ben Skeggs 2017-06-12 23:03:59 UTC
The issue is known, and a patch has been sent upstream.  I believe Greg has queued it for the various stable trees already, but I don't see it in a tagged release yet.

Comment 4 Laura Abbott 2017-06-13 23:26:29 UTC
*** Bug 1461211 has been marked as a duplicate of this bug. ***

Comment 5 Mike 2017-06-14 14:38:34 UTC
Just as an FYI, this bug still appears in kernel-4.11.4-200.fc25.x86_64

Comment 6 Laura Abbott 2017-06-14 23:07:51 UTC
I believe 4.11.5 should have the fix so please test https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644

Comment 7 Mike 2017-06-15 02:08:41 UTC
(In reply to Laura Abbott from comment #6)
> I believe 4.11.5 should have the fix so please test
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644

Hi Laura,

I can confirm that I can boot, and run the 4.11.5 kernel.

Comment 8 Fedora Update System 2017-06-15 14:50:48 UTC
kernel-4.11.5-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644

Comment 9 Laura Abbott 2017-06-16 17:52:02 UTC
*** Bug 1445312 has been marked as a duplicate of this bug. ***

Comment 10 Albert Vernon 2017-06-16 18:46:57 UTC
I can confirm that 4.11.5 fixes this problem for me.

Comment 11 Fedora Update System 2017-06-16 18:52:11 UTC
kernel-4.11.5-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.