Bug 1460585 - Revert CLI restrictions on running rebalance in VM store use case
Revert CLI restrictions on running rebalance in VM store use case
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On:
Blocks: 1460993 1460997
  Show dependency treegraph
 
Reported: 2017-06-12 02:19 EDT by Krutika Dhananjay
Modified: 2017-09-05 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1460993 1460997 (view as bug list)
Environment:
Last Closed: 2017-09-05 13:33:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2017-06-12 02:19:32 EDT
Description of problem:

Now that some of the users have confirmed rebalance works fine in VM store environments when parallel IO is going on, and sas has also confirmed the same, time to revert the CLI restrictions wrt running rebalance on sharded volumes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-06-12 02:34:33 EDT
REVIEW: https://review.gluster.org/17506 (Revert "glusterd: disallow rebalance & remove-brick on a sharded volume") posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Worker Ant 2017-06-13 04:51:48 EDT
COMMIT: https://review.gluster.org/17506 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit c0d4081cf4b90a4316b786cc53263a7c56fdb344
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jun 12 11:17:01 2017 +0530

    Revert "glusterd: disallow rebalance & remove-brick on a sharded volume"
    
    This reverts commit 8375b3d70d5c6268c6770b42a18b2e1bc09e411e.
    
    Now that some of the users have confirmed rebalance works fine without
    causing corruption of VMs, time to revert the CLI restriction.
    
    Change-Id: I45493fcbb1f25fd0fff27b2b3526c42642ccb464
    BUG: 1460585
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/17506
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 3 Shyamsundar 2017-09-05 13:33:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.