Bug 1460997 - Revert CLI restrictions on running rebalance in VM store use case
Revert CLI restrictions on running rebalance in VM store use case
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.11
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On: 1460585
Blocks: 1460993
  Show dependency treegraph
 
Reported: 2017-06-13 06:30 EDT by Krutika Dhananjay
Modified: 2017-06-28 14:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.11.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1460585
Environment:
Last Closed: 2017-06-28 14:32:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2017-06-13 06:30:38 EDT
+++ This bug was initially created as a clone of Bug #1460585 +++

Description of problem:

Now that some of the users have confirmed rebalance works fine in VM store environments when parallel IO is going on, and sas has also confirmed the same, time to revert the CLI restrictions wrt running rebalance on sharded volumes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-06-12 02:34:33 EDT ---

REVIEW: https://review.gluster.org/17506 (Revert "glusterd: disallow rebalance & remove-brick on a sharded volume") posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Worker Ant on 2017-06-13 04:51:48 EDT ---

COMMIT: https://review.gluster.org/17506 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit c0d4081cf4b90a4316b786cc53263a7c56fdb344
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jun 12 11:17:01 2017 +0530

    Revert "glusterd: disallow rebalance & remove-brick on a sharded volume"
    
    This reverts commit 8375b3d70d5c6268c6770b42a18b2e1bc09e411e.
    
    Now that some of the users have confirmed rebalance works fine without
    causing corruption of VMs, time to revert the CLI restriction.
    
    Change-Id: I45493fcbb1f25fd0fff27b2b3526c42642ccb464
    BUG: 1460585
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/17506
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 1 Worker Ant 2017-06-13 06:33:14 EDT
REVIEW: https://review.gluster.org/17533 (Revert "glusterd: disallow rebalance & remove-brick on a sharded volume") posted (#1) for review on release-3.11 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Worker Ant 2017-06-16 04:26:03 EDT
REVIEW: https://review.gluster.org/17533 (Revert "glusterd: disallow rebalance & remove-brick on a sharded volume") posted (#2) for review on release-3.11 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Worker Ant 2017-06-19 11:48:29 EDT
COMMIT: https://review.gluster.org/17533 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 9c5403587517b5922cb87bff75033839e96d56ab
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jun 12 11:17:01 2017 +0530

    Revert "glusterd: disallow rebalance & remove-brick on a sharded volume"
    
    This reverts commit 8375b3d70d5c6268c6770b42a18b2e1bc09e411e.
    
    Backport of:
    > Change-Id: I45493fcbb1f25fd0fff27b2b3526c42642ccb464
    > BUG: 1460585
    > Reviewed-on: https://review.gluster.org/17506
    > (cherry-picked from c0d4081cf4b90a4316b786cc53263a7c56fdb344)
    
    Now that some of the users have confirmed rebalance works fine without
    causing corruption of VMs, time to revert the CLI restriction.
    
    Change-Id: I45493fcbb1f25fd0fff27b2b3526c42642ccb464
    BUG: 1460997
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/17533
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Shyamsundar 2017-06-28 14:32:55 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.1, please open a new bug report.

glusterfs-3.11.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-June/000074.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.